summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancisco Blas (klondike) Izquierdo Riera <klondike@gentoo.org>2021-02-26 13:34:04 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-28 10:04:02 +0200
commit27c0a064ddc4c780307282ecbabf46f905a3145c (patch)
tree560c2e60728aacdbba2f49ae5593b7acc6072449 /net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
parentnet-p2p/eiskaltdcpp: Fix upnp compilation (diff)
downloadgentoo-27c0a064ddc4c780307282ecbabf46f905a3145c.tar.gz
gentoo-27c0a064ddc4c780307282ecbabf46f905a3145c.tar.bz2
gentoo-27c0a064ddc4c780307282ecbabf46f905a3145c.zip
net-p2p/eiskaltdcpp: Drop XML-RPC support
It fails to compile with newer versions of Eiskaltdc++ and upstream is already planning to drop it (see [1]). Patching the daemon to fix these errors is not trivial and this codepath may introduce other issues as it is not well tested. While we are at this, also merge JSON support with the daemon and cli USE flags as there is no point on keeping it as a separated USE flag. If you intend to readd ZML-RPC, please first write a patch that addresses the compilation issues. [1] https://github.com/eiskaltdcpp/eiskaltdcpp/issues/440 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Francisco Blas Izquierdo Riera (klondike) <klondike@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/18854 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild')
-rw-r--r--net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild26
1 files changed, 7 insertions, 19 deletions
diff --git a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
index 8467b419629b..315afa716827 100644
--- a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
+++ b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
@@ -15,11 +15,9 @@ HOMEPAGE="https://github.com/eiskaltdcpp/eiskaltdcpp"
LICENSE="GPL-2 GPL-3"
SLOT="0"
-IUSE="cli daemon dbus +dht examples gold gtk idn javascript +json libcanberra libnotify lua +minimal pcre +qt5 spell sqlite upnp xmlrpc"
+IUSE="cli daemon dbus +dht examples gold gtk idn javascript libcanberra libnotify lua +minimal pcre +qt5 spell sqlite upnp"
REQUIRED_USE="
- ?? ( json xmlrpc )
- cli? ( ^^ ( json xmlrpc ) )
dbus? ( qt5 )
javascript? ( qt5 )
libcanberra? ( gtk )
@@ -34,6 +32,7 @@ if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
else
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ KEYWORDS=""
fi
RDEPEND="
@@ -48,12 +47,10 @@ RDEPEND="
dev-perl/Data-Dump
dev-perl/Term-ShellUI
virtual/perl-Getopt-Long
- json? ( dev-perl/JSON-RPC )
- xmlrpc? ( dev-perl/RPC-XML )
+ dev-perl/JSON-RPC
)
daemon? (
- json? ( dev-libs/jsoncpp:= )
- xmlrpc? ( dev-libs/xmlrpc-c[abyss,cxx] )
+ dev-libs/jsoncpp:=
)
gtk? (
dev-libs/glib:2
@@ -97,6 +94,7 @@ DOCS=( AUTHORS ChangeLog.txt )
PATCHES=(
"${FILESDIR}/${PN}-2.2.10-cmake_lua_version.patch"
+ "${FILESDIR}/${P}-fix_upnp_compilation.patch"
)
CMAKE_REMOVE_MODULES_LIST="FindLua"
@@ -138,19 +136,9 @@ src_configure() {
-DBUILD_STATIC=OFF
-DINSTALL_QT_TRANSLATIONS=OFF
-DCOMPRESS_MANPAGES=OFF
+ -DUSE_CLI_JSONRPC=$(usex cli)
+ -DJSONRPC_DAEMON=$(usex daemon)
)
- if use cli; then
- mycmakeargs+=(
- -DUSE_CLI_JSONRPC=$(usex json)
- -DUSE_CLI_XMLRPC=$(usex xmlrpc)
- )
- fi
- if use daemon; then
- mycmakeargs+=(
- -DJSONRPC_DAEMON=$(usex json)
- -DXMLRPC_DAEMON=$(usex xmlrpc)
- )
- fi
if use lua; then
mycmakeargs+=(
-DLUA_SCRIPT=ON