summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-28 08:16:45 +0000
committerSam James <sam@gentoo.org>2022-01-28 08:16:45 +0000
commita4ea51ed76e14ce71a889558c9fe5ef4c5c64114 (patch)
tree4c54010f9b89ee350c584c77600bb8d3af3603fc /net-proxy
parentdev-embedded/platformio: keyword 5.2.4-r1 for ~x86 (diff)
downloadgentoo-a4ea51ed76e14ce71a889558c9fe5ef4c5c64114.tar.gz
gentoo-a4ea51ed76e14ce71a889558c9fe5ef4c5c64114.tar.bz2
gentoo-a4ea51ed76e14ce71a889558c9fe5ef4c5c64114.zip
net-proxy/sshuttle: add 1.1.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/sshuttle/Manifest1
-rw-r--r--net-proxy/sshuttle/sshuttle-1.1.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index ae1788a02dc2..58aa627072b4 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1 +1,2 @@
DIST sshuttle-1.0.5.tar.gz 88823 BLAKE2B 6a68be71a92c8245e2e60df1f425c6959547f8c2b972bdafcd774449c3779698c2549f2c7a3575c102158962ef9dd2edaaecec564f36f7f5cc84ed3f53b3daa3 SHA512 a9ebc8f8cf5ccc351796c2eb5b224b5d76908d23a367b768fa4e7b9cd8517ee7ff9c232c92ed4332f46d02d890ad8114f8beaa66876a8c0d7d4850c18ff4c2b3
+DIST sshuttle-1.1.0.tar.gz 93987 BLAKE2B c81ab591d5f84764a6ed114623ccb1aaf2ff9706bc5f494513b19c4c2eeb218f3777b2bc7042329eb862aa311a5eab56669d88e10d92b019c0ff9ac9381e3903 SHA512 86361dec179c2ae61c338abaec3d0d36a280c1cc719c1df245a98379037315ac71781e8e5599bb50e34f5068dab3e1010cd7d15c614e01f3dc12011b620d43ee
diff --git a/net-proxy/sshuttle/sshuttle-1.1.0.ebuild b/net-proxy/sshuttle/sshuttle-1.1.0.ebuild
new file mode 100644
index 000000000000..809e9d48926c
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-1.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.org/project/sshuttle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/sphinx
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ || ( net-firewall/iptables net-firewall/nftables )
+"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~NF_NAT"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Don't run tests via setup.py pytest
+ sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
+
+ # Don't require pytest-cov when running tests
+ sed -i "s/^addopts =/#\0/" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -j1 -C docs html man
+}
+
+python_install_all() {
+ HTML_DOCS=( docs/_build/html/. )
+
+ doman docs/_build/man/*
+
+ distutils-r1_python_install_all
+}