summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-12-18 14:13:59 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-12-18 14:15:07 -0600
commiteef40905196d3abce2ddd5efc5e9320135a391db (patch)
tree8b26febc600384d8c5be9522552fb5827587ee38 /net-vpn
parentllvm-runtimes/offload: Keyword 19.1.6 arm64, #946609 (diff)
downloadgentoo-eef40905196d3abce2ddd5efc5e9320135a391db.tar.gz
gentoo-eef40905196d3abce2ddd5efc5e9320135a391db.tar.bz2
gentoo-eef40905196d3abce2ddd5efc5e9320135a391db.zip
net-vpn/tailscale: add 1.78.3
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.78.3.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index 879d12fc2986..6cae4fa35b51 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -1,2 +1,4 @@
DIST tailscale-1.78.1-deps.tar.xz 265614604 BLAKE2B 590c750ff34b3044793ebffc433583e5d904b19d5aaa7926f644c0251df3b5cad32f3da06daa1cfb16bdeb50f63e62c21f893515aa2cae8d2be04b81233c8664 SHA512 6a738f98a9eba65ccc8989c9edaa24fa4db545c0d10a973613066734b7f379f99261eb4d5e8f49345d314336891fb6c9e9a45456784a38963b4a552147fbc631
DIST tailscale-1.78.1.tar.gz 3378628 BLAKE2B f8f6dfaf5498eb7a230035373d1b1d501da3296e394083d26870596bacf5e6a1f4d849a016dc652ba3e416de960a2a5483aa5e3b44b33b6759f42959cd7208ab SHA512 1286971554f15c601ee36050cbe361170de2ea4955fc8dde01a4a231f966a1049b9d85d2854637077c1900d4e67ef15352250e412f9e13b2d1cb6b34b2dce05a
+DIST tailscale-1.78.3-deps.tar.xz 265496184 BLAKE2B de585f36dfcb0cca5234df06b7395de7e7f84f74b31c14ded548bbd7202865697646e6108c820f55b7d76758ca284a8c461c1fd715140262208b864608c1ab1b SHA512 c67a62081fba3cb4c61e0eec22915d6bd535173d2936e3214b63af93109dcb38293d0bcc4649f7382772f65d6c5d35fde7b4fb5b9eff28e114f091b858c10175
+DIST tailscale-1.78.3.tar.gz 3378578 BLAKE2B d36d549875e2a20fcff0112636d0dce1a206c66e9f06498959072a4fb5f97bf3b63841f27ebe89aad14d403eb3ac0f3d3835da2d6a4c17dc4d2bfd369d868875 SHA512 555de6801c10cc3d5b61eae3bf01d14f9e7b80f39adc2ab35dc70adea11fecc396ade52423028d584d0a13cfac01f23aea39be641f63a6621bcc4ef11077391c
diff --git a/net-vpn/tailscale/tailscale-1.78.3.ebuild b/net-vpn/tailscale/tailscale-1.78.3.ebuild
new file mode 100644
index 000000000000..d4a71a28913d
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.78.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module linux-info systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+# They should be updated on every bump.
+VERSION_MINOR="78"
+VERSION_SHORT="1.78.3"
+VERSION_LONG="1.78.3-t1b41fdedd"
+VERSION_GIT_HASH="1b41fdeddb6598b35ba15cc6b07740e0cc0e8411"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+CONFIG_CHECK="~TUN"
+
+RDEPEND="net-firewall/iptables"
+BDEPEND=">=dev-lang/go-1.22"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.longStamp=${VERSION_LONG}
+ -X tailscale.com/version.shortStamp=${VERSION_SHORT}
+ -X tailscale.com/version.gitCommitStamp=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}