summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-02-19 11:48:36 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-02-19 12:29:13 -0500
commit979c6f51ad2baf630f21536be923d3fa3b84bec2 (patch)
tree4538120445f51a1ef3b5015370db914c13322029 /net-wireless/soapyuhd/soapyuhd-9999.ebuild
parentnet-wireless/bladerf: update to latest rc (diff)
downloadgentoo-979c6f51ad2baf630f21536be923d3fa3b84bec2.tar.gz
gentoo-979c6f51ad2baf630f21536be923d3fa3b84bec2.tar.bz2
gentoo-979c6f51ad2baf630f21536be923d3fa3b84bec2.zip
net-wireless/soapyuhd: import from pentoo
module for soapysdr Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-wireless/soapyuhd/soapyuhd-9999.ebuild')
-rw-r--r--net-wireless/soapyuhd/soapyuhd-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-wireless/soapyuhd/soapyuhd-9999.ebuild b/net-wireless/soapyuhd/soapyuhd-9999.ebuild
new file mode 100644
index 000000000000..626e9029a89c
--- /dev/null
+++ b/net-wireless/soapyuhd/soapyuhd-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Soapy SDR plugins for UHD supported SDR devices "
+HOMEPAGE="https://github.com/pothosware/SoapyUHD"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyUHD.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyUHD/archive/soapy-uhd-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyUHD-soapy-uhd-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-wireless/uhd:=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"