summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-12-26 22:54:40 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-12-29 21:30:53 +0000
commit8c8c938e158a9e10f1c5a4280c16e435e354122e (patch)
tree9a6f140a7c1dfd4f845d059d5e816dcd618c789f /profiles
parentdev-texlive/texlive-luatex: Stabilize 2021-r2 arm64, #888890 (diff)
downloadgentoo-8c8c938e158a9e10f1c5a4280c16e435e354122e.tar.gz
gentoo-8c8c938e158a9e10f1c5a4280c16e435e354122e.tar.bz2
gentoo-8c8c938e158a9e10f1c5a4280c16e435e354122e.zip
dev-lang/python: Fix cross-compiling for prefixed systems
Cross-compiling Python involves doing a native build first. The prefix profile prefixifies setup.py, but this has been done before the native build when it needs to be done after. Handle this in the ebuild with hprefixify instead of with sed in the profile. Also drop some other obsolete Python prefix hacks from the profile. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'profiles')
-rw-r--r--profiles/features/prefix/standalone/profile.bashrc11
1 files changed, 0 insertions, 11 deletions
diff --git a/profiles/features/prefix/standalone/profile.bashrc b/profiles/features/prefix/standalone/profile.bashrc
index d23eeb81797d..fd95e43f7f30 100644
--- a/profiles/features/prefix/standalone/profile.bashrc
+++ b/profiles/features/prefix/standalone/profile.bashrc
@@ -74,17 +74,6 @@ elif [[ ${CATEGORY}/${PN} == sys-libs/glibc && ${EBUILD_PHASE} == configure ]];
-e "s,/(etc|var),${EPREFIX}/\1,g" \
nss/db-Makefile
eend $?
-elif [[ ${CATEGORY}/${PN} == dev-lang/python && ${EBUILD_PHASE} == configure ]]; then
- # Guide h2py to look into glibc of Prefix
- ebegin "Guiding h2py to look into Prefix"
- export include="${EPREFIX}"/usr/include
- sed -i -r \
- -e "s,/usr/include,\"${EPREFIX}\"/usr/include,g" "${S}"/Lib/plat-linux*/regen
- eend $?
- ebegin "Prefixifying distutils paths"
- sed -re "s,([^[:alnum:]])(/usr[/[:alnum:]]*/(lib[[:alnum:]]*|include)|/lib[[:alnum:]]*),\1${EPREFIX}\2,g" \
- -i "${S}"/setup.py
- eend $?
elif [[ ${CATEGORY}/${PN} == dev-lang/perl && ${EBUILD_PHASE} == configure ]]; then
ebegin "Prefixifying pwd path"
sed -r "s,'((|/usr)/bin/pwd),'${EPREFIX}\1," -i "${S}"/dist/PathTools/Cwd.pm