summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-07 19:14:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-02 13:20:37 +0200
commitaa5e606c70e257749eb885e69215ba48fac9ecad (patch)
treeb1218eb5ecbb1d04987f368b83adcb06e0dfdd18 /sci-astronomy
parentkde-misc/tellico: EAPI-8 bump (diff)
downloadgentoo-aa5e606c70e257749eb885e69215ba48fac9ecad.tar.gz
gentoo-aa5e606c70e257749eb885e69215ba48fac9ecad.tar.bz2
gentoo-aa5e606c70e257749eb885e69215ba48fac9ecad.zip
sci-astronomy/kstars: 3.5.5 version bump
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/kstars/Manifest1
-rw-r--r--sci-astronomy/kstars/files/kstars-3.5.5-FindERFA.cmake.patch125
-rw-r--r--sci-astronomy/kstars/kstars-3.5.5.ebuild100
3 files changed, 226 insertions, 0 deletions
diff --git a/sci-astronomy/kstars/Manifest b/sci-astronomy/kstars/Manifest
index 3ff6b55029c8..846b1abcbb24 100644
--- a/sci-astronomy/kstars/Manifest
+++ b/sci-astronomy/kstars/Manifest
@@ -1 +1,2 @@
DIST kstars-3.5.3.tar.xz 79228112 BLAKE2B c82e76398630a657887a8b6720a801bce74bb2ebff5bb86f4546672794709a68c970c897074e9cc6846210250ad2d05e2b53af75b70ef2c0fa5504be12aa592b SHA512 383071130fa4674ba373cba2ecd46143a9cdef9f9e636f0bf33f66d9302baa913af4aa1713ba871dd7cee6eed95d8196055a02ab41c24e2729d74950aea742f8
+DIST kstars-3.5.5.tar.xz 79302220 BLAKE2B df8503c72c689301e70345169491dbc8e27116b44c75a78088f91da0d103965f4da359d4de22c3a177898cfe734f66b06810440c2d4dd7ec15862f0ad4d4edf0 SHA512 03ed4db0e3998c9501f77fb22e26046177d4bc427e769be1964ba3d54701a1240908117bc65424768917252710b73811e38ec61e2391182794b30ad6c9d68d96
diff --git a/sci-astronomy/kstars/files/kstars-3.5.5-FindERFA.cmake.patch b/sci-astronomy/kstars/files/kstars-3.5.5-FindERFA.cmake.patch
new file mode 100644
index 000000000000..920cdf9c72b5
--- /dev/null
+++ b/sci-astronomy/kstars/files/kstars-3.5.5-FindERFA.cmake.patch
@@ -0,0 +1,125 @@
+From b920b785f8193414fd66fe2a6d69c2e2ebf22023 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Tue, 21 Sep 2021 16:56:02 +0200
+Subject: [PATCH] Add FindERFA cmake module
+
+ERFA doesn't seem to come with a cmake find module or a config file,
+so I wrote one, which also provides an imported target.
+---
+ CMakeLists.txt | 5 +--
+ Tests/skyobjects/CMakeLists.txt | 5 ++-
+ cmake/modules/FindERFA.cmake | 72 +++++++++++++++++++++++++++++++++
+ 3 files changed, 77 insertions(+), 5 deletions(-)
+ create mode 100644 cmake/modules/FindERFA.cmake
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b7b02258a..052987438 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -229,10 +229,7 @@ if(BUILD_TESTING)
+ # Find liberfa, which we check our computation against
+ find_package(ERFA)
+ MACRO_BOOL_TO_01(ERFA_FOUND HAVE_LIBERFA)
+- set_package_properties(ERFA PROPERTIES DESCRIPTION "Essential Routines for Fundamental Astronomy" URL "https://github.com/liberfa/erfa" TYPE OPTIONAL PURPOSE "BSD-compatible version of SOFA, used to test core computations of KStars (only needed by tests)")
+- if (ERFA_FOUND)
+- include_directories(${ERFA_INCLUDE_DIR})
+- endif()
++ set_package_properties(ERFA PROPERTIES TYPE OPTIONAL PURPOSE "BSD-compatible version of SOFA, used to test core computations of KStars (only needed by tests)")
+ endif ()
+
+ ## Libraw
+diff --git a/Tests/skyobjects/CMakeLists.txt b/Tests/skyobjects/CMakeLists.txt
+index 7dc9b918c..ca2d06209 100644
+--- a/Tests/skyobjects/CMakeLists.txt
++++ b/Tests/skyobjects/CMakeLists.txt
+@@ -5,5 +5,8 @@ ADD_TEST( NAME TestSkyPoint COMMAND test_skypoint )
+ endif()
+
+ ADD_EXECUTABLE( test_starobject test_starobject.cpp )
+-TARGET_LINK_LIBRARIES( test_starobject ${TEST_LIBRARIES} ${ERFA_LIBRARIES})
++TARGET_LINK_LIBRARIES( test_starobject ${TEST_LIBRARIES} )
++if (TARGET ERFA::ERFA)
++ TARGET_LINK_LIBRARIES( test_starobject ERFA::ERFA )
++endif()
+ ADD_TEST( NAME TestStarobject COMMAND test_starobject )
+diff --git a/cmake/modules/FindERFA.cmake b/cmake/modules/FindERFA.cmake
+new file mode 100644
+index 000000000..ea6f3e7d8
+--- /dev/null
++++ b/cmake/modules/FindERFA.cmake
+@@ -0,0 +1,72 @@
++# SPDX-FileCopyrightText: 2021 Heiko Becker <heiko.becker@kde.org>
++#
++# SPDX-License-Identifier: BSD-3-Clause
++
++#[=======================================================================[.rst:
++FindERFA
++----------
++
++Try to find the ERFA (Essential Routines for Fundamental Astronomy) library.
++
++This will define the following variables:
++
++``ERFA_FOUND``
++ True if the system has the ERFA library of at least the minimum
++ version specified by the version parameter to find_package()
++``ERFA_INCLUDE_DIRS``
++ The ERFA include dirs for use with target_include_directories
++``ERFA_LIBRARIES``
++ The ERFA libraries for use with target_link_libraries()
++``ERFA_VERSION``
++ The version of ERFA that was found
++
++If ``ERFA_FOUND` is TRUE, it will also define the following imported
++target:
++
++``ERFA::ERFA``
++ The ERFA library
++
++#]=======================================================================]
++
++find_package(PkgConfig QUIET)
++
++pkg_check_modules(PC_ERFA QUIET erfa)
++
++find_path(ERFA_INCLUDE_DIRS
++ NAMES erfa.h
++ HINTS ${PC_ERFA_INCLUDEDIR}
++)
++
++find_library(ERFA_LIBRARIES
++ NAMES erfa
++ HINTS ${PC_ERFA_LIBDIR}
++)
++
++set(ERFA_VERSION ${PC_ERFA_VERSION})
++
++include(FindPackageHandleStandardArgs)
++find_package_handle_standard_args(ERFA
++ FOUND_VAR
++ ERFA_FOUND
++ REQUIRED_VARS
++ ERFA_LIBRARIES
++ ERFA_INCLUDE_DIRS
++ VERSION_VAR
++ ERFA_VERSION
++)
++
++if (ERFA_FOUND AND NOT TARGET ERFA::ERFA)
++ add_library(ERFA::ERFA UNKNOWN IMPORTED)
++ set_target_properties(ERFA::ERFA PROPERTIES
++ IMPORTED_LOCATION "${ERFA_LIBRARIES}"
++ INTERFACE_INCLUDE_DIRECTORIES "${ERFA_INCLUDE_DIRS}"
++ )
++endif()
++
++mark_as_advanced(ERFA_LIBRARIES ERFA_INCLUDE_DIRS)
++
++include(FeatureSummary)
++set_package_properties(ERFA PROPERTIES
++ URL "https://github.com/liberfa/erfa/"
++ DESCRIPTION "Essential Routines for Fundamental Astronomy"
++)
+--
+GitLab
+
diff --git a/sci-astronomy/kstars/kstars-3.5.5.ebuild b/sci-astronomy/kstars/kstars-3.5.5.ebuild
new file mode 100644
index 000000000000..204ec4d9076e
--- /dev/null
+++ b/sci-astronomy/kstars/kstars-3.5.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.82.0
+QTMIN=5.15.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="Desktop Planetarium"
+HOMEPAGE="https://apps.kde.org/kstars/ https://edu.kde.org/kstars/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="5"
+IUSE="fits indi +password raw wcs"
+
+REQUIRED_USE="indi? ( fits ) ${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ >=dev-qt/qtdatavis3d-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwebsockets-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kplotting-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ sys-libs/zlib
+ fits? ( sci-libs/cfitsio:= )
+ indi? (
+ sci-libs/gsl:=
+ >=sci-libs/indilib-1.9.1
+ sci-libs/libnova:=
+ sci-libs/stellarsolver
+ )
+ password? ( dev-libs/qtkeychain:= )
+ raw? ( media-libs/libraw:= )
+ wcs? ( sci-astronomy/wcslib:= )
+"
+# TODO: Add back when re-enabled by upstream
+# opengl? (
+# >=dev-qt/qtopengl-${QTMIN}:5
+# virtual/opengl
+# )
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:3
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtpositioning-${QTMIN}:5
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-FindERFA.cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DFETCH_TRANSLATIONS=OFF
+ -DBUILD_PYKSTARS=OFF
+ -DBUILD_DOC=$(usex handbook)
+ $(cmake_use_find_package fits CFitsio)
+ $(cmake_use_find_package indi INDI)
+ $(cmake_use_find_package indi Nova)
+ $(cmake_use_find_package password Qt5Keychain)
+ $(cmake_use_find_package raw LibRaw)
+ $(cmake_use_find_package wcs WCSLIB)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Display 'current' pictures of planets" x11-misc/xplanet
+ fi
+ ecm_pkg_postinst
+}