summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-22 14:06:34 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-22 14:06:34 +0200
commit422ca7a3d7fbb0f7e0a63a4f19934281226dcc49 (patch)
treedc7f19aed960e19ede2589005bd7f06a9ca0ef68 /sci-biology/biopython/biopython-1.73.ebuild
parentprofiles/package.mask: masked media-libs/slv2 for removal (diff)
downloadgentoo-422ca7a3d7fbb0f7e0a63a4f19934281226dcc49.tar.gz
gentoo-422ca7a3d7fbb0f7e0a63a4f19934281226dcc49.tar.bz2
gentoo-422ca7a3d7fbb0f7e0a63a4f19934281226dcc49.zip
sci-biology/biopython: Remove old 1.73
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology/biopython/biopython-1.73.ebuild')
-rw-r--r--sci-biology/biopython/biopython-1.73.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/sci-biology/biopython/biopython-1.73.ebuild b/sci-biology/biopython/biopython-1.73.ebuild
deleted file mode 100644
index 94acdfc2a2cb..000000000000
--- a/sci-biology/biopython/biopython-1.73.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="https://www.biopython.org/ https://pypi.org/project/biopython/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rdflib[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- >=dev-python/reportlab-3.5.13-r1[${PYTHON_USEDEP}]
- dev-python/pydot[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- sys-devel/flex"
-
-DOCS=( {CONTRIB,DEPRECATED,NEWS,README}.rst Doc/. )
-
-python_test() {
- distutils_install_for_testing
- cp -r "${S}"/{Doc,Tests} "${TEST_DIR}"/lib/ || die
- cd "${TEST_DIR}"/lib/Tests || die
- rm test_BioSQL_{psycopg2.py,MySQLdb.py,mysql_connector.py} || die
- "${EPYTHON}" run_tests.py --offline --verbose || die
-}
-
-python_install_all() {
- # remove files causing ecompressdir to fail
- rm Doc/examples/ls_orchid.gbk.{gz,bz2} || die
-
- distutils-r1_python_install_all
-
- dodir /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
-}
-
-pkg_postinst() {
- elog "For database support you need to install:"
- optfeature "MySQL" dev-python/mysql-python
- optfeature "PostgreSQL" dev-python/psycopg
-
- elog "Some applications need extra packages:"
- optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
-}