summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/plink
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/plink')
-rw-r--r--sci-biology/plink/Manifest2
-rw-r--r--sci-biology/plink/files/1.07-flags.patch44
-rw-r--r--sci-biology/plink/files/plink-1.07-gcc47.patch64
-rw-r--r--sci-biology/plink/metadata.xml13
-rw-r--r--sci-biology/plink/plink-1.07-r1.ebuild48
-rw-r--r--sci-biology/plink/plink-1.90_pre140514.ebuild55
6 files changed, 226 insertions, 0 deletions
diff --git a/sci-biology/plink/Manifest b/sci-biology/plink/Manifest
new file mode 100644
index 000000000000..1bd3f237d4c8
--- /dev/null
+++ b/sci-biology/plink/Manifest
@@ -0,0 +1,2 @@
+DIST plink-1.07-src.zip 2257297 SHA256 4af56348443d0c6a1db64950a071b1fcb49cc74154875a7b43cccb4b6a7f482b SHA512 493f9f32ecd9eb20c5d11dc8ac98c47a9e695059cec3d1ad6f17465b71609577032368c0fee0d3d564e9451c3c07761e444717bec0f4628caefc587fceb1f6c3 WHIRLPOOL 01e69f605e1b52c6087dd75b506a7705d3bdb8e7dfdd0158e125f4fc4d962fad70c4ec430a139029b3b4ae91b822eb10123fab062c6552b946ec96ca7caf37da
+DIST plink-1.90_pre140514.zip 822157 SHA256 c6f93153d079b4b7f9ae4a51a3b4dcc7bc5ed60b408d39fce6234b98570b8ea7 SHA512 679f1e136b11f35f1d49636bc44ffd17e72e4e38edc5daa270cd963ca39f7b8a80f31905a94de517059e5b3ea7a6bf518ae34a5c2af8a05c530bd6df771606c4 WHIRLPOOL ebcccc1dc0461afd973aa63313237bfd5d904543785115fa71f3af1925d8bb21da15bd0baf60e38f4da534c8c554202a7af6c642b274ca9a458fc0035c2758d2
diff --git a/sci-biology/plink/files/1.07-flags.patch b/sci-biology/plink/files/1.07-flags.patch
new file mode 100644
index 000000000000..aa130f29beb2
--- /dev/null
+++ b/sci-biology/plink/files/1.07-flags.patch
@@ -0,0 +1,44 @@
+diff --git a/Makefile b/Makefile
+index 172c795..466f09f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,25 +26,25 @@ WITH_R_PLUGINS = 1
+ WITH_WEBCHECK = 1
+ FORCE_32BIT =
+ WITH_ZLIB = 1
+-WITH_LAPACK =
+-FORCE_DYNAMIC =
++WITH_LAPACK = 1
++FORCE_DYNAMIC = 1
+
+ # Put C++ compiler here; Windows has it's own specific version
+ CXX_UNIX = g++
+ CXX_WIN = c:\bin\mingw\bin\mingw32-g++.exe
+
+ # Any other compiler flags here ( -Wall, -g, etc)
+-CXXFLAGS =
++CXXFLAGS ?= -O2
+
+ # Misc
+-LIB_LAPACK = /usr/lib/liblapack.so.3
++LIB_LAPACK = `$(PKG_CONFIG) --libs lapack`
+
+
+ # --------------------------------------------------------------------
+ # Do not edit below this line
+ # --------------------------------------------------------------------
+
+-CXXFLAGS += -O3 -I.
++CXXFLAGS += -I.
+ OUTPUT = plink
+
+ # Some system specific flags
+@@ -151,7 +151,7 @@ OBJ = $(SRC:.cpp=.o)
+ all : $(OUTPUT)
+
+ $(OUTPUT) :
+- $(CXX) $(CXXFLAGS) -o $(OUTPUT) $(OBJ) $(LIB)
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o $(OUTPUT) $(OBJ) $(LIB)
+
+ $(OBJ) : $(HDR)
+
diff --git a/sci-biology/plink/files/plink-1.07-gcc47.patch b/sci-biology/plink/files/plink-1.07-gcc47.patch
new file mode 100644
index 000000000000..6c289edae153
--- /dev/null
+++ b/sci-biology/plink/files/plink-1.07-gcc47.patch
@@ -0,0 +1,64 @@
+ elf.cpp | 6 +++---
+ idhelp.cpp | 8 ++++----
+ sets.cpp | 8 ++++----
+ 3 files changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/elf.cpp b/elf.cpp
+index ec2ed3d..a57665f 100644
+--- a/elf.cpp
++++ b/elf.cpp
+@@ -1175,10 +1175,10 @@ void Plink::elfBaseline()
+ << setw(8) << gcnt << " "
+ << setw(8) << (double)cnt / (double)gcnt << "\n";
+
+- map<int,int>::iterator i = chr_cnt.begin();
+- while ( i != chr_cnt.end() )
++ map<int,int>::iterator j = chr_cnt.begin();
++ while ( j != chr_cnt.end() )
+ {
+- int c = i->first;
++ int c = j->first;
+ int x = chr_cnt.find( c )->second;
+ int y = chr_gcnt.find( c )->second;
+
+diff --git a/idhelp.cpp b/idhelp.cpp
+index a9244fa..8882097 100644
+--- a/idhelp.cpp
++++ b/idhelp.cpp
+@@ -772,12 +772,12 @@ void IDHelper::idHelp()
+ for (int j = 0 ; j < jointField.size(); j++ )
+ {
+ set<IDField*> & jf = jointField[j];
+- set<IDField*>::iterator j = jf.begin();
++ set<IDField*>::iterator k = jf.begin();
+ PP->printLOG(" { ");
+- while ( j != jf.end() )
++ while ( k != jf.end() )
+ {
+- PP->printLOG( (*j)->name + " " );
+- ++j;
++ PP->printLOG( (*k)->name + " " );
++ ++k;
+ }
+ PP->printLOG(" }");
+ }
+diff --git a/sets.cpp b/sets.cpp
+index 3a8f92f..66787e8 100644
+--- a/sets.cpp
++++ b/sets.cpp
+@@ -768,11 +768,11 @@ vector_t Set::profileTestScore()
+ //////////////////////////////////////////////
+ // Reset original missing status
+
+- vector<Individual*>::iterator i = PP->sample.begin();
+- while ( i != PP->sample.end() )
++ vector<Individual*>::iterator j = PP->sample.begin();
++ while ( j != PP->sample.end() )
+ {
+- (*i)->missing = (*i)->flag;
+- ++i;
++ (*j)->missing = (*j)->flag;
++ ++j;
+ }
+
+ ////////////////////////////////////////////////
diff --git a/sci-biology/plink/metadata.xml b/sci-biology/plink/metadata.xml
new file mode 100644
index 000000000000..80af0e1d0365
--- /dev/null
+++ b/sci-biology/plink/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <use>
+ <flag name="webcheck">
+ add support for online update checking every time the program starts
+ </flag>
+ <flag name="R">
+ add support R language
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-biology/plink/plink-1.07-r1.ebuild b/sci-biology/plink/plink-1.07-r1.ebuild
new file mode 100644
index 000000000000..ca32ecf62a18
--- /dev/null
+++ b/sci-biology/plink/plink-1.07-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Whole genome association analysis toolset"
+HOMEPAGE="http://pngu.mgh.harvard.edu/~purcell/plink/"
+SRC_URI="http://pngu.mgh.harvard.edu/~purcell/plink/dist/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="lapack -webcheck R"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ app-arch/unzip
+ lapack? ( virtual/pkgconfig )"
+RDEPEND="
+ sys-libs/zlib
+ lapack? ( virtual/lapack )"
+
+S="${WORKDIR}/${P}-src"
+
+# Package collides with net-misc/putty. Renamed to p-link following discussion with Debian.
+# Package contains bytecode-only jar gPLINK.jar. Ignored, notified upstream.
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-flags.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+ use webcheck || sed -i '/WITH_WEBCHECK =/ s/^/#/' "${S}/Makefile" || die
+ use R || sed -i '/WITH_R_PLUGINS =/ s/^/#/' "${S}/Makefile" || die
+ use lapack || sed -i '/WITH_LAPACK =/ s/^/#/' "${S}/Makefile" || die
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ emake \
+ CXX_UNIX=$(tc-getCXX)
+}
+
+src_install() {
+ newbin plink p-link
+ dodoc README.txt
+}
diff --git a/sci-biology/plink/plink-1.90_pre140514.ebuild b/sci-biology/plink/plink-1.90_pre140514.ebuild
new file mode 100644
index 000000000000..45b80be23c36
--- /dev/null
+++ b/sci-biology/plink/plink-1.90_pre140514.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Whole genome association analysis toolset"
+HOMEPAGE="http://pngu.mgh.harvard.edu/~purcell/plink/"
+SRC_URI="http://pngu.mgh.harvard.edu/~purcell/static/bin/plink140514/plink_src.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-arch/unzip
+ virtual/pkgconfig"
+RDEPEND="
+ sys-libs/zlib
+ virtual/cblas
+ virtual/lapack
+ "
+
+S="${WORKDIR}/"
+
+# Package collides with net-misc/putty. Renamed to p-link following discussion with Debian.
+# Package contains bytecode-only jar gPLINK.jar. Ignored, notified upstream.
+
+src_prepare() {
+ sed \
+ -e 's:zlib-1.2.8/zlib.h:zlib.h:g' \
+ -i *.{c,h} || die
+
+ sed \
+ -e 's:g++:$(CXX):g' \
+ -e 's:gcc:$(CC):g' \
+ -e 's:gfortran:$(FC):g' \
+ -i Makefile || die
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ emake \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ ZLIB="$($(tc-getPKG_CONFIG) --libs zlib)" \
+ BLASFLAGS="$($(tc-getPKG_CONFIG) --libs lapack cblas)"
+}
+
+src_install() {
+ newbin plink p-link
+}