summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-02 12:44:42 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-02 13:04:41 +0200
commitadb3bc8e64f8afe51ae31d8070b98f2a88a243ee (patch)
tree7d03d254694354924d8bd37d8a92f55b6a055d1e /sci-biology/pysam/pysam-0.12.ebuild
parentsci-visualization/visit: remove unused patches (diff)
downloadgentoo-adb3bc8e64f8afe51ae31d8070b98f2a88a243ee.tar.gz
gentoo-adb3bc8e64f8afe51ae31d8070b98f2a88a243ee.tar.bz2
gentoo-adb3bc8e64f8afe51ae31d8070b98f2a88a243ee.zip
sci-biology/pysam: Bump to 0.12
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sci-biology/pysam/pysam-0.12.ebuild')
-rw-r--r--sci-biology/pysam/pysam-0.12.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/pysam/pysam-0.12.ebuild b/sci-biology/pysam/pysam-0.12.ebuild
new file mode 100644
index 000000000000..e181e06ac9bc
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="
+ https://github.com/pysam-developers/pysam
+ https://pypi.python.org/pypi/pysam"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sci-libs/htslib-1.5*:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ export HTSLIB_INCLUDE_DIR="${EPREFIX}"/usr/include
+ export HTSLIB_LIBRARY_DIR="${EPREFIX}"/usr/$(get_libdir)
+ export HTSLIB_CONFIGURE_OPTIONS="--disable-libcurl"
+
+ # prevent setup.py from adding RPATHs
+ sed -e "/ext\.extra_link_args += \['-Wl,-rpath,\$ORIGIN'\]/d" \
+ -i cy_build.py || die
+ sed -e '/runtime_library_dirs=htslib_library_dirs/d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ # TODO
+ # empty compile, as the build system runs the whole build again in install
+ :
+}