summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/t-coffee/t-coffee-9.03.1318-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/t-coffee/t-coffee-9.03.1318-r1.ebuild')
-rw-r--r--sci-biology/t-coffee/t-coffee-9.03.1318-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-biology/t-coffee/t-coffee-9.03.1318-r1.ebuild b/sci-biology/t-coffee/t-coffee-9.03.1318-r1.ebuild
new file mode 100644
index 000000000000..4b56c05793b5
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-9.03.1318-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic fortran-2 toolchain-funcs versionator
+
+MY_PV="$(replace_version_separator 2 .r)"
+MY_P="T-COFFEE_distribution_Version_${MY_PV}"
+
+DESCRIPTION="A multiple sequence alignment package"
+HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://www.tcoffee.org/Packages/Stable/Version_${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ sci-biology/clustalw
+ sci-chemistry/tm-align"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+die_compile() {
+ echo
+ eerror "If you experience an internal compiler error (consult the above"
+ eerror "messages), try compiling t-coffee using very modest compiler flags."
+ eerror "See bug #114745 on the Gentoo Bugzilla for more details."
+ die "Compilation failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ [[ $(gcc-version) == "3.4" ]] || \
+ [[ $(gcc-version) == "4.1" ]] && \
+ append-flags -fno-unit-at-a-time
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ -C t_coffee_source t_coffee
+}
+
+src_install() {
+ dobin t_coffee_source/t_coffee
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r example
+ fi
+}