summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-03-26 12:06:22 +0100
committerDavid Seifert <soap@gentoo.org>2024-03-26 12:06:22 +0100
commit9e53125a7a6ae8c74dc0b154c9f14498a4bbfb0d (patch)
tree290d4b1d4a21467621f60d758fd60d0881633eb1 /sci-biology
parentsci-biology/samtools: add 1.19.2 (diff)
downloadgentoo-9e53125a7a6ae8c74dc0b154c9f14498a4bbfb0d.tar.gz
gentoo-9e53125a7a6ae8c74dc0b154c9f14498a4bbfb0d.tar.bz2
gentoo-9e53125a7a6ae8c74dc0b154c9f14498a4bbfb0d.zip
sci-biology/bcftools: add 1.19
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bcftools/Manifest1
-rw-r--r--sci-biology/bcftools/bcftools-1.19.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index 0f3c24a476a9..9cbcbdd02db5 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1 +1,2 @@
DIST bcftools-1.17.tar.bz2 7538043 BLAKE2B 82f65d53ebea0527ff000329f158ebdb1d603e04841a096cf8ca0434e7a5694ab43da7959ee10e9cb29328bf82301c03200e1203578a74e2e1118856b2641502 SHA512 39ae44a682e626a5261900e9412170a269e460b559d6607db697e6a12b1e512ffb3bdeb3486413e19b8adca26a8ccbb2bd4af24459decb74592c54473d2c6a68
+DIST bcftools-1.19.tar.bz2 7906216 BLAKE2B 43e7ac0fc6ffcf837607fb2fbbd58a72106a89b018d1fd4b24db0eb854a9bf0efd0c7762fae84bf7f51226346777be646d134159ea48e3eb3df71799e9353a3f SHA512 a203c65fa58fca8fb5276e73ed8fc23dfd841e9dc05881304a8b91327d60ac3b5fcf5a55a1f1bab5647037f037ff30f2881791052f6e29cf38c646cbc947a746
diff --git a/sci-biology/bcftools/bcftools-1.19.ebuild b/sci-biology/bcftools/bcftools-1.19.ebuild
new file mode 100644
index 000000000000..27d474fe35f9
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]')
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{gff2gff,guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}