summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2020-04-10 23:33:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-19 19:37:53 +0200
commit9b77b1c007312f8e4261a409fe36ea07caff7415 (patch)
tree38a01598b9378a7ab2bb02da79776b3109663850 /sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild
parentsci-chemistry/gperiodic: update HOMEPAGE (diff)
downloadgentoo-9b77b1c007312f8e4261a409fe36ea07caff7415.tar.gz
gentoo-9b77b1c007312f8e4261a409fe36ea07caff7415.tar.bz2
gentoo-9b77b1c007312f8e4261a409fe36ea07caff7415.zip
sci-chemistry/gperiodic: bump to 3.0.3, EAPI=7
Closes: https://bugs.gentoo.org/707580 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild')
-rw-r--r--sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild b/sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild
new file mode 100644
index 000000000000..a7c510e90e38
--- /dev/null
+++ b/sci-chemistry/gperiodic/gperiodic-3.0.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs xdg-utils
+
+DESCRIPTION="Periodic table application for Linux"
+HOMEPAGE="https://sourceforge.net/projects/gperiodic/"
+SRC_URI="https://downloads.sourceforge.net/project/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls"
+MY_AVAILABLE_LINGUAS=" be bg cs da de es fi fr gl id is it lt ms nl pl pt_BR pt ru sv tr uk"
+
+RDEPEND="
+ sys-libs/ncurses:0
+ x11-libs/gtk+:2
+ x11-libs/cairo[X]
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ for lang in ${MY_AVAILABLE_LINGUAS}; do
+ if ! has ${lang} ${LINGUAS-${lang}}; then
+ einfo "Cleaning translation for ${lang}"
+ rm po/${lang}.po || die
+ fi
+ done
+}
+
+src_compile() {
+ local myopts
+ use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC=$(tc-getCC) ${myopts}
+}
+
+src_install() {
+ local myopts
+ use nls && myopts="enable_nls=1" || myopts="enable_nls=0"
+ emake DESTDIR="${D}" ${myopts} install
+ dodoc AUTHORS ChangeLog README
+ newdoc po/README README.translation
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}