summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/pymol-plugins-caver
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/pymol-plugins-caver')
-rw-r--r--sci-chemistry/pymol-plugins-caver/Manifest1
-rw-r--r--sci-chemistry/pymol-plugins-caver/metadata.xml5
-rw-r--r--sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild54
3 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-caver/Manifest b/sci-chemistry/pymol-plugins-caver/Manifest
new file mode 100644
index 000000000000..ecfe07a54c4b
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-caver/Manifest
@@ -0,0 +1 @@
+DIST Caver2_1_2_pymol_plugin.zip 5698331 SHA256 1dcc61ba13247c05710c4cd68491d0c867ce1d0c11c824be85a516250b2874e3 SHA512 9d28e059bb20f30cf6a0d25ed2eb080dcf9dbb753e9d4578d95e293b31c5cf5fe23d5177dccdb79c192ab3e65bb484b6eb22b26c267637b125404f871e01a52c WHIRLPOOL 33e6893d2114b5ce197fc098d09dfc67ce88f38741e30f1fa574873836c636b5e0c180301849fd98f1f93de5ce51554d2245d0bd615b938d39a802e91e68ebb9
diff --git a/sci-chemistry/pymol-plugins-caver/metadata.xml b/sci-chemistry/pymol-plugins-caver/metadata.xml
new file mode 100644
index 000000000000..51fdedab1b38
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-caver/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild b/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild
new file mode 100644
index 000000000000..a07aef903771
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-caver/pymol-plugins-caver-2.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib python-r1 eutils versionator java-utils-2
+
+MY_PV="$(replace_all_version_separators _)"
+MY_P="Caver${MY_PV}_pymol_plugin"
+
+DESCRIPTION="Calculation of pathways from buried cavities to outside solvent in protein structures"
+HOMEPAGE="http://loschmidt.chemi.muni.cz/caver/"
+SRC_URI="${MY_P}.zip"
+
+LICENSE="CAVER"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6
+ sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/${MY_P}"/linux_mac
+
+pkg_nofetch() {
+ elog "Download ${A}"
+ elog "from ${HOMEPAGE}. This requires registration."
+ elog "Place tarballs in ${DISTDIR}."
+}
+
+src_install() {
+ java-pkg_dojar Caver${MY_PV}/*.jar
+
+ java-pkg_jarinto /usr/share/${PN}/lib/lib/
+ java-pkg_dojar Caver${MY_PV}/lib/*.jar
+
+ installation() {
+ sed \
+ -e "s:directory/where/jar/with/plugin/is/located:${EPREFIX}/usr/share/${PN}/lib/:g" \
+ -i Caver${MY_PV}.py || die
+
+ python_moduleinto pmg_tk/startup/
+ python_domodule Caver${MY_PV}.py
+ python_optimize
+ }
+ python_foreach_impl installation
+}