summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/shelx/shelx-20141228.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/shelx/shelx-20141228.ebuild')
-rw-r--r--sci-chemistry/shelx/shelx-20141228.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/shelx/shelx-20141228.ebuild b/sci-chemistry/shelx/shelx-20141228.ebuild
new file mode 100644
index 000000000000..dfd2eac4f5f3
--- /dev/null
+++ b/sci-chemistry/shelx/shelx-20141228.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Programs for crystal structure determination from single-crystal diffraction data"
+HOMEPAGE="http://shelx.uni-ac.gwdg.de/SHELX/"
+SRC_URI="
+ amd64? (
+ anode_amd64.bz2
+ ciftab_amd64.bz2
+ shelxc_amd64.bz2
+ shelxd_amd64.bz2
+ shelxe_amd64.bz2
+ shelxl_amd64.bz2
+ shelxs_amd64.bz2
+ shelxt_amd64.bz2
+ shredcif_amd64.bz2
+ )
+ x86? (
+ anode_x86.bz2
+ ciftab_x86.bz2
+ shelxc_x86.bz2
+ shelxd_x86.bz2
+ shelxe_x86.bz2
+ shelxl_x86.bz2
+ shelxs_x86.bz2
+ shelxt_x86.bz2
+ shredcif_x86.bz2
+ )
+"
+
+SLOT="0"
+LICENSE="free-noncomm"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"
+
+RESTRICT="fetch"
+
+QA_PREBUILT="opt/bin/*"
+
+pkg_nofetch() {
+ elog "Go to ${HOMEPAGE}"
+ elog "Fill out the application form, and send it in."
+ elog "Download ${A} and rename them to"
+ use amd64 && elog "*_amd64.bz2"
+ use x86 && elog "*_x86.bz2"
+ elog "and place renamed tarballs in ${DISTDIR}."
+}
+
+src_install() {
+ local i
+ into /opt
+ for i in *; do
+ newbin ${i} ${i/_*/}
+ done
+}