summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-12 13:15:05 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-12 13:28:27 +0100
commita261106159eb12c438a339ecaed0587dd4fe1197 (patch)
treeb1732b1b31d048d357b6a4cc6d0ce6d8afb42e81 /sci-chemistry
parentgnome-extra/gnome-shell-extension-desktop-icons-ng: drop 47.0.3 (diff)
downloadgentoo-a261106159eb12c438a339ecaed0587dd4fe1197.tar.gz
gentoo-a261106159eb12c438a339ecaed0587dd4fe1197.tar.bz2
gentoo-a261106159eb12c438a339ecaed0587dd4fe1197.zip
sci-chemistry/chemtool: Use transfig from fig2dev
Also use a better icon for Adamantane and drop useless USE flags. Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/chemtool/Manifest1
-rw-r--r--sci-chemistry/chemtool/chemtool-1.6.14-r1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-chemistry/chemtool/Manifest b/sci-chemistry/chemtool/Manifest
index 17ef99cab669..60ea9764c148 100644
--- a/sci-chemistry/chemtool/Manifest
+++ b/sci-chemistry/chemtool/Manifest
@@ -1 +1,2 @@
DIST chemtool-1.6.14.tar.gz 817735 BLAKE2B 065c5069402b5960fc2c9b686a9c0e9954b98c43a1d70385ca56e8407fffbe09fd87023f1f7177140745987c69731766f64a8b8015370ef38593bbcd3f073e64 SHA512 066c83c61aced3134b081767e788143a047889a2fee4b6535c2b0a3166bccc73d75981e1cf35b7bcaa5b8fe2e0227b28693b659decd82f7783cb4082ac6ed2bd
+DIST chemtool.png 1601 BLAKE2B f443547954baf296b15ae8604b84df0a5a23c3bb92df3c0f6f7e8f1d7b7ae67a90a39b9e0a50a4c5105d1f6de2796caf37d67d7a8e872dc026386486109b185b SHA512 3402a3e096dc0f8a40bced0259992478950e5bddd16281cf6b2c8f819f45964d2fd30644f5d6e81c6d72028d5d298c39621369433670f3733d8940be14044a21
diff --git a/sci-chemistry/chemtool/chemtool-1.6.14-r1.ebuild b/sci-chemistry/chemtool/chemtool-1.6.14-r1.ebuild
new file mode 100644
index 000000000000..cddf65f0df6c
--- /dev/null
+++ b/sci-chemistry/chemtool/chemtool-1.6.14-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools desktop
+
+DESCRIPTION="A GTK program for drawing organic molecules"
+HOMEPAGE="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/"
+SRC_URI="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/${P}.tar.gz
+ https://upload.wikimedia.org/wikipedia/commons/5/58/Adamantane_acsv.svg -> chemtool.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="emf"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=media-gfx/fig2dev-3.2.9-r1
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ emf? ( media-libs/libemf )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-underlinking.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-fix-tests.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-undo \
+ --enable-menu \
+ --without-kdedir \
+ $(use_enable emf)
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/chemtool/examples
+ doins -r examples/.
+
+ doicon "${DISTDIR}"/chemtool.png
+ make_desktop_entry chemtool Chemtool chemtool "Education;Science;Chemistry"
+}