summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-05-18 11:20:51 +0200
committerPacho Ramos <pacho@gentoo.org>2024-05-18 11:23:04 +0200
commitc5f2c621136bfc67183c410a60713763fd0f7bdf (patch)
tree38256b7824108bfd28926bbfd4c555f10de01832 /sci-chemistry
parentgui-libs/gdk-pixbuf-loader-webp: Fix EmptyGlobalAssignment warn (diff)
downloadgentoo-c5f2c621136bfc67183c410a60713763fd0f7bdf.tar.gz
gentoo-c5f2c621136bfc67183c410a60713763fd0f7bdf.tar.bz2
gentoo-c5f2c621136bfc67183c410a60713763fd0f7bdf.zip
sci-chemistry/chemex: add 2024.02.16
Closes: https://bugs.gentoo.org/929756 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/chemex/Manifest1
-rw-r--r--sci-chemistry/chemex/chemex-2024.02.16.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/Manifest b/sci-chemistry/chemex/Manifest
index 119d4ed88136..5d90ff1b85bc 100644
--- a/sci-chemistry/chemex/Manifest
+++ b/sci-chemistry/chemex/Manifest
@@ -1,2 +1,3 @@
DIST chemex-2022.3.5.tar.gz 2845347 BLAKE2B 29b53ba8afcfd91e4f50119f212557de85d8576474b74d2ad925c8c2adb89397640e7b352b6785dc99a8c4e5007294609640219b2374cbb3144f94c5f9113d96 SHA512 3a92702d105e95e0a7b15e01b839d5982df55477afb98e58f7458a0e87230e94597c01d33c219ae469ed62e4ddaecdb787ae435453d428843d5a612159715d2b
DIST chemex-2022.3.6.tar.gz 2843118 BLAKE2B e51b385dbf9e3c42f54f95f9929125e3263e12afa62beab8e5b8eb13e78a4fe9a0fb445f4f6c3cd4aa8e71748732ec58124682daa86be079eed036b78492ca71 SHA512 5c734e1b3ea39e9729bada93dfe5bc55f877b69ba6edd9612f95aab0d31949489582957a14f175646c7e6652644a5a55c26bcd74affc7fecc1e7b9cfdd4ceb63
+DIST chemex-2024.02.16.tar.gz 2756466 BLAKE2B 715499fc3c68079dd66b26a0c4c495029c506be6f009529196fd30a1ec8ff4c0ecbcc4580c9beafd4f3c7df82d6fee525d85c09b031a6dc31d511c1183d30f8d SHA512 7975157b86493c580ce00ef23549597743ff4aa03cebed7d0e0af1d644eed359b5dfa57c51e11f223acebe335d12cb43bd7694a46eeb2ccba70ac6147ba40eda
diff --git a/sci-chemistry/chemex/chemex-2024.02.16.ebuild b/sci-chemistry/chemex/chemex-2024.02.16.ebuild
new file mode 100644
index 000000000000..73c1e4bae504
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2024.02.16.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/annotated-types-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-5.3.2[${PYTHON_USEDEP}]
+ >=dev-python/emcee-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.26.1[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.6.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.11.3[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}