summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/ngspice/ngspice-26.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/ngspice/ngspice-26.ebuild')
-rw-r--r--sci-electronics/ngspice/ngspice-26.ebuild103
1 files changed, 103 insertions, 0 deletions
diff --git a/sci-electronics/ngspice/ngspice-26.ebuild b/sci-electronics/ngspice/ngspice-26.ebuild
new file mode 100644
index 000000000000..484abd9bcdbd
--- /dev/null
+++ b/sci-electronics/ngspice/ngspice-26.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="The Next Generation Spice (Electronic Circuit Simulator)"
+SRC_URI="mirror://sourceforge/ngspice/${P}.tar.gz
+ mirror://sourceforge/ngspice/${PN}-${PV}-manual.pdf"
+HOMEPAGE="http://ngspice.sourceforge.net"
+LICENSE="BSD GPL-2"
+
+SLOT="0"
+IUSE="X debug readline"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="sys-libs/ncurses
+ readline? ( >=sys-libs/readline-5.0 )
+ X? ( x11-libs/libXaw
+ x11-libs/libXt
+ x11-libs/libX11
+ sci-visualization/xgraph )"
+
+RDEPEND="$DEPEND"
+
+src_prepare() {
+ sed -e '/CFLAGS=/s: -s::' -i configure.ac || die "sed failed"
+ sed -e 's/_CFLAGS -O2/_CFLAGS/' -i configure.ac || die "sed failed"
+ sed -e 's/LDFLAGS =/LDFLAGS +=/' -i src/xspice/icm/makedefs.in || die "sed failed"
+ sed -e '/AM_INIT_AUTOMAKE/s:-Werror::' -i configure.ac || die "sed failed"
+ # builds also with ncurses[tinfo] (bug #458128)
+ sed -e 's/ncurses termcap/ncurses termcap tinfo/g' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local MYCONF
+ if use debug ; then
+ MYCONF="--enable-debug \
+ --enable-ftedebug \
+ --enable-cpdebug \
+ --enable-asdebug \
+ --enable-stepdebug \
+ --enable-pzdebug"
+ else
+ MYCONF="--disable-debug \
+ --disable-ftedebug \
+ --disable-cpdebug \
+ --disable-asdebug \
+ --disable-stepdebug \
+ --disable-pzdebug"
+ fi
+ # Those don't compile
+ MYCONF="${MYCONF} \
+ --disable-sensdebug \
+ --disable-blktmsdebug \
+ --disable-smltmsdebug"
+
+ econf \
+ ${MYCONF} \
+ --enable-xspice \
+ --enable-cider \
+ --enable-ndev \
+ --disable-xgraph \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ $(use_with X x) \
+ $(use_with readline)
+}
+
+# These will need to be looked at some day:
+# --enable-adms
+# --enable-nodelimiting
+# --enable-predictor
+# --enable-newtrunc
+# --enable-openmp
+
+src_install () {
+ local infoFile
+ for infoFile in doc/ngspice.info*; do
+ echo 'INFO-DIR-SECTION EDA' >> ${infoFile}
+ echo 'START-INFO-DIR-ENTRY' >> ${infoFile}
+ echo '* NGSPICE: (ngspice). Electronic Circuit Simulator.' >> ${infoFile}
+ echo 'END-INFO-DIR-ENTRY' >> ${infoFile}
+ done
+
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ANALYSES AUTHORS BUGS ChangeLog DEVICES NEWS \
+ README Stuarts_Poly_Notes || die "failed to install documentation"
+
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}-${PV}-manual.pdf || die "failed to install manual"
+
+ # We don't need ngmakeidx to be installed
+ rm "${D}"/usr/bin/ngmakeidx
+}
+
+src_test () {
+ # Bug 108405
+ true
+}