summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2021-07-03 17:46:30 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2021-07-03 17:47:36 +0200
commit23e6cad3c576c32f97ad857da284e51a88ae9da1 (patch)
tree58a843084b49f8f11c0670ef236beda0f5e38281 /sci-electronics/puff/puff-20100127-r1.ebuild
parentapp-text/apvlv: update HOMEPAGE (diff)
downloadgentoo-23e6cad3c576c32f97ad857da284e51a88ae9da1.tar.gz
gentoo-23e6cad3c576c32f97ad857da284e51a88ae9da1.tar.bz2
gentoo-23e6cad3c576c32f97ad857da284e51a88ae9da1.zip
sci-electronics/puff: Do not call 'ld' directly
Closes: https://bugs.gentoo.org/799440 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-electronics/puff/puff-20100127-r1.ebuild')
-rw-r--r--sci-electronics/puff/puff-20100127-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sci-electronics/puff/puff-20100127-r1.ebuild b/sci-electronics/puff/puff-20100127-r1.ebuild
index 1c89266a7936..3ec8bccda1fa 100644
--- a/sci-electronics/puff/puff-20100127-r1.ebuild
+++ b/sci-electronics/puff/puff-20100127-r1.ebuild
@@ -20,16 +20,14 @@ DEPEND="${RDEPEND}
src_prepare() {
default
# fix lib path for X11 and dont ignore LDFLAGS
- sed -i -e "s#lib\\\/#$(get_libdir)\\\/#" \
- -e 's/CFLAGS/#CFLAGS/' \
- -e 's/CC =/#CC =/' \
- -e 's/link.res/.res/g' \
- -e 's/.res pu/.res $(LDFLAGS) pu/' Makefile || die
+ # respect CC and LD
+ eapply -p0 "${FILESDIR}"/$P-Makefile.patch
+ eapply_user
}
src_compile() {
LDFLAGS="$(raw-ldflags)"
- emake -j1 CC="$(tc-getCC)"
+ emake -j1 CC="$(tc-getCC)" LD="$(tc-getLD)"
}
src_install() {