summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-16 16:19:28 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-16 16:19:28 +0100
commit61f9a098fe26f9e6683e43178a8cc93dd1886ed4 (patch)
tree1d672b91ba8daeb7ca6271651c861248d77f49c2 /sci-geosciences/folium
parentsci-geosciences/folium: drop 0.15.1-r2, 0.16.0 (diff)
downloadgentoo-61f9a098fe26f9e6683e43178a8cc93dd1886ed4.tar.gz
gentoo-61f9a098fe26f9e6683e43178a8cc93dd1886ed4.tar.bz2
gentoo-61f9a098fe26f9e6683e43178a8cc93dd1886ed4.zip
sci-geosciences/folium: add 0.18.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-geosciences/folium')
-rw-r--r--sci-geosciences/folium/Manifest1
-rw-r--r--sci-geosciences/folium/folium-0.18.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-geosciences/folium/Manifest b/sci-geosciences/folium/Manifest
index 11a862b1046d..64f4846142f1 100644
--- a/sci-geosciences/folium/Manifest
+++ b/sci-geosciences/folium/Manifest
@@ -1 +1,2 @@
DIST folium-0.17.0.tar.gz 8212314 BLAKE2B aac66b49fee5633e6c5d097094cc4ff21d835f87c5017384f2e39236aece1f4820c0dad80b87abcbce30ddb2a3c48332656b0ad07cecdd5b2dbf81c9329eb852 SHA512 2f45237064ea0bd07f95c53ab482bb33bd1786cd431237df23f1d2b9f5f063c43a0f590236b408d257e2567c16444651e9fe1a4ec9c13e6f4934a0330c7d86cc
+DIST folium-0.18.0.tar.gz 8193343 BLAKE2B d36bedfc8038bd71bc0f22ab0c998bab8b32f8e521c32a6a9b0f6f0cc8d1804310346d7531d83e96efc3f804de1eeef5e2ec851b67b9a5e79ab64d42d5410e60 SHA512 a37dfa47b5bd256298df151ad48d71dfeaf5170c6b4e02d28a3f73aa749cfaf931e4ee91110dd3d027f047d46f309111beeca52dfcfafebe5f38597421ecb3c2
diff --git a/sci-geosciences/folium/folium-0.18.0.ebuild b/sci-geosciences/folium/folium-0.18.0.ebuild
new file mode 100644
index 000000000000..4aa2aa656206
--- /dev/null
+++ b/sci-geosciences/folium/folium-0.18.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="Python Data, Leaflet.js Maps"
+HOMEPAGE="https://github.com/python-visualization/folium"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.1-gentoo.patch
+)
+
+RDEPEND="sci-geosciences/xyzservices[${PYTHON_USEDEP}]
+ sci-libs/branca[${PYTHON_USEDEP}]
+ dev-python/jinja2[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools-scm
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r tests/selenium || die # require chromedriver
+ rm tests/test_folium.py || die # require geopandas
+ rm tests/test_raster_layers.py || die # require xyzservices
+ rm tests/plugins/test_time_slider_choropleth.py || die # require geopandas
+ rm tests/test_repr.py || die # require geckodriver
+ default
+}
+
+python_test() {
+ epytest -m 'not web'
+}