summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2022-06-02 20:07:49 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-06-08 10:12:11 +0200
commitfe6d375af0f7b57016f4fd18c2a099f01d4e816c (patch)
treef493988c4016f674244fc5617212084d132f3d83 /sci-geosciences/josm-bin
parentdev-java/xml-commons-resolver: add missing resources and Main-Class (diff)
downloadgentoo-fe6d375af0f7b57016f4fd18c2a099f01d4e816c.tar.gz
gentoo-fe6d375af0f7b57016f4fd18c2a099f01d4e816c.tar.bz2
gentoo-fe6d375af0f7b57016f4fd18c2a099f01d4e816c.zip
sci-geosciences/josm-bin: version bump to 18463
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/25730 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sci-geosciences/josm-bin')
-rw-r--r--sci-geosciences/josm-bin/Manifest1
-rw-r--r--sci-geosciences/josm-bin/josm-bin-18463.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-geosciences/josm-bin/Manifest b/sci-geosciences/josm-bin/Manifest
index 1430b59618ab..4492cf81377d 100644
--- a/sci-geosciences/josm-bin/Manifest
+++ b/sci-geosciences/josm-bin/Manifest
@@ -1 +1,2 @@
DIST josm-snapshot-18427.jar 16255913 BLAKE2B 9c47d32ab2e199645aa84b6ccdec710cb95e93df7b7c5745378aa2338ead4bd3ad851bca91b701de4f2e4f9e815fb8a6b71aa203c81e2ec323cc43d8d79fe110 SHA512 5269c3bba5d0376c4da9eb9cd561429d9b92ee554b458fd00f3e93607420cdbcdcc5389b58966a15b6ef2a3b94d3bb4bb5d421c5e28e1b6575369df44ed96f87
+DIST josm-snapshot-18463.jar 16273803 BLAKE2B 043121ca1e7512207608dfaa549a53d70532a6844028f2fb2554fc187e41f4220a5aec9032c734356f6f1f42478c5bdb74d7498a9c45929daa430e89ba61c64f SHA512 46152f16a3a019d9231a27f584e5bd8b5865c01e2a9bf94179c81c69fd32fcf532b6d02222e41bf431c3981a0bf375ce7be17551b3c2d7fb0734671bc4e59071
diff --git a/sci-geosciences/josm-bin/josm-bin-18463.ebuild b/sci-geosciences/josm-bin/josm-bin-18463.ebuild
new file mode 100644
index 000000000000..3a5ff50d232a
--- /dev/null
+++ b/sci-geosciences/josm-bin/josm-bin-18463.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop java-utils-2 xdg
+
+DESCRIPTION="Java-based editor for the OpenStreetMap project"
+HOMEPAGE="https://josm.openstreetmap.de/"
+SRC_URI="https://josm.openstreetmap.de/download/josm-snapshot-${PV}.jar"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 GPL-2+ GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8"
+BDEPEND="app-arch/unzip"
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}/${A}" ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+
+ local icon_size
+ for icon_size in 16 32 48; do
+ newicon -s ${icon_size} -t hicolor \
+ images/logo_${icon_size}x${icon_size}x32.png ${PN}.png
+ newicon -s ${icon_size} -t locolor \
+ images/logo_${icon_size}x${icon_size}x8.png ${PN}.png
+ done
+ make_desktop_entry ${PN} "Java OpenStreetMap Editor" ${PN} "Utility;Science;Geoscience"
+}