summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-01-22 07:05:38 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 07:06:29 -0500
commit66f19e13ac53efa018d12a375912e6c4789b7e51 (patch)
tree6d821d4cfdcc77754d14ec5b98b8ef52812498bb /sci-libs/bliss
parentmedia-plugins/vdr-extrecmenu: Fix wrong p-level of patch (diff)
downloadgentoo-66f19e13ac53efa018d12a375912e6c4789b7e51.tar.gz
gentoo-66f19e13ac53efa018d12a375912e6c4789b7e51.tar.bz2
gentoo-66f19e13ac53efa018d12a375912e6c4789b7e51.zip
sci-libs/bliss: fix libbliss underlinking in a new revision
Closes: https://bugs.gentoo.org/922651 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/bliss')
-rw-r--r--sci-libs/bliss/bliss-0.77-r1.ebuild31
-rw-r--r--sci-libs/bliss/files/bliss-0.77-libbliss-underlinking.patch16
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/bliss/bliss-0.77-r1.ebuild b/sci-libs/bliss/bliss-0.77-r1.ebuild
new file mode 100644
index 000000000000..af5467295b07
--- /dev/null
+++ b/sci-libs/bliss/bliss-0.77-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+SRC_URI="https://users.aalto.fi/~tjunttil/${PN}/downloads/${P}.zip"
+DESCRIPTION="Compute Automorphism Groups and Canonical Labelings of Graphs"
+HOMEPAGE="https://users.aalto.fi/~tjunttil/bliss/index.html"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="gmp"
+
+RDEPEND="gmp? ( dev-libs/gmp:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.77-install.patch"
+ "${FILESDIR}/${PN}-0.77-libbliss-underlinking.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GMP="$(usex gmp)"
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-libs/bliss/files/bliss-0.77-libbliss-underlinking.patch b/sci-libs/bliss/files/bliss-0.77-libbliss-underlinking.patch
new file mode 100644
index 000000000000..faf04d7ae6e3
--- /dev/null
+++ b/sci-libs/bliss/files/bliss-0.77-libbliss-underlinking.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/922651
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index cfdb0a6..e0fd51a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -51,6 +51,9 @@ endif(MSVC)
+ # Add the shared library
+ add_library(bliss SHARED ${BLISS_SOURCE_FILES})
+ set_property(TARGET bliss PROPERTY POSITION_INDEPENDENT_CODE 1)
++if(USE_GMP)
++ target_link_libraries(bliss ${GMP_LIBRARIES})
++endif(USE_GMP)
+
+ # Add the static library
+ add_library(bliss_static STATIC ${BLISS_SOURCE_FILES})