summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-01-16 14:55:16 +1300
committerMichael Orlitzky <mjo@gentoo.org>2021-01-15 21:03:49 -0500
commit4e61159117a7d1a3490460dec8c37c7fbeec4c08 (patch)
tree9ef6c4140f44b3efde6f5e8eeab3a86be4a36f34 /sci-libs/camd
parentsci-libs/amd: fix bashism in doc building (diff)
downloadgentoo-4e61159117a7d1a3490460dec8c37c7fbeec4c08.tar.gz
gentoo-4e61159117a7d1a3490460dec8c37c7fbeec4c08.tar.bz2
gentoo-4e61159117a7d1a3490460dec8c37c7fbeec4c08.zip
sci-libs/camd: fix bashism in doc building
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Bug: https://bugs.gentoo.org/760408 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/camd')
-rw-r--r--sci-libs/camd/camd-2.4.6-r1.ebuild41
-rw-r--r--sci-libs/camd/files/camd-2.4.6-dash_doc.patch16
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/camd/camd-2.4.6-r1.ebuild b/sci-libs/camd/camd-2.4.6-r1.ebuild
new file mode 100644
index 000000000000..fb5a430ed408
--- /dev/null
+++ b/sci-libs/camd/camd-2.4.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="https://people.engr.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+DEPEND=">=sci-libs/suitesparseconfig-5.4.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.4.6-dash_doc.patch )
+
+src_prepare(){
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with doc)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/camd/files/camd-2.4.6-dash_doc.patch b/sci-libs/camd/files/camd-2.4.6-dash_doc.patch
new file mode 100644
index 000000000000..c70ed070f2a3
--- /dev/null
+++ b/sci-libs/camd/files/camd-2.4.6-dash_doc.patch
@@ -0,0 +1,16 @@
+diff --git a/Doc/Makefile.am b/Doc/Makefile.am
+index 80f5653..71c130a 100644
+--- a/Doc/Makefile.am
++++ b/Doc/Makefile.am
+@@ -1,9 +1,8 @@
+
+ CAMD_UserGuide.pdf:
+- echo '\begin{verbatim}' > camd_h.tex
++ printf '\\begin{verbatim}\n' > camd_h.tex
+ expand -8 $(top_srcdir)/Include/camd.h >> camd_h.tex
+- echo '\end{verbatim}' >> camd_h.tex
+- -ln -s $(srcdir)/*.{tex,bib} .
++ printf '\\end{verbatim}\n' >> camd_h.tex
+ $(PDFLATEX) CAMD_UserGuide
+ $(BIBTEX) CAMD_UserGuide
+ $(PDFLATEX) CAMD_UserGuide