summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-21 02:18:49 -0400
committerSam James <sam@gentoo.org>2024-03-22 05:31:48 +0000
commit90b59711f3e353e4a8a07488a8adf1c655caa99b (patch)
tree5d4c81d18a003f4a5feeb7488d92403016ba6cb8 /sci-libs/cddlib
parentsci-libs/libmuscle: update EAPI 6 -> 8 (diff)
downloadgentoo-90b59711f3e353e4a8a07488a8adf1c655caa99b.tar.gz
gentoo-90b59711f3e353e4a8a07488a8adf1c655caa99b.tar.bz2
gentoo-90b59711f3e353e4a8a07488a8adf1c655caa99b.zip
sci-libs/cddlib: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/cddlib')
-rw-r--r--sci-libs/cddlib/cddlib-094m-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sci-libs/cddlib/cddlib-094m-r1.ebuild b/sci-libs/cddlib/cddlib-094m-r1.ebuild
index 5cb23824058f..4a38f957054c 100644
--- a/sci-libs/cddlib/cddlib-094m-r1.ebuild
+++ b/sci-libs/cddlib/cddlib-094m-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit libtool
+
# This can't work forever; but for now, it's better than hard-coding the
# correct version string.
MY_PV="${PV:0:1}.${PV:1}"
@@ -23,6 +25,11 @@ RDEPEND="dev-libs/gmp:0="
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf $(use_enable static-libs static)
}