summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/gamer/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/gamer/files')
-rw-r--r--sci-libs/gamer/files/1.4-doc.patch20
-rw-r--r--sci-libs/gamer/files/1.4-multilib.patch26
-rw-r--r--sci-libs/gamer/files/1.5-underlinking.patch42
3 files changed, 88 insertions, 0 deletions
diff --git a/sci-libs/gamer/files/1.4-doc.patch b/sci-libs/gamer/files/1.4-doc.patch
new file mode 100644
index 000000000000..642601bcc17b
--- /dev/null
+++ b/sci-libs/gamer/files/1.4-doc.patch
@@ -0,0 +1,20 @@
+diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
+index 4067c1c..43867e2 100644
+--- a/doc/doxygen/Makefile.am
++++ b/doc/doxygen/Makefile.am
+@@ -9,13 +9,11 @@
+ ## Author: Michael Holst
+ ## ###########################################################################
+
+-docdir = @prefix@/doc/gamer
+-
+ doc_DATA = gamer_doc
+
+ gamer_doc:
+ $(doxygen_path) $(top_srcdir)/doc/doxygen/gamer.dox
+
+ install-docDATA:
+- mkdir -p $(docdir)
+- cp -r ../api $(docdir)/
++ mkdir -p $(DESTDIR)/@docdir@
++ cp -r ../api $(DESTDIR)/@docdir@
diff --git a/sci-libs/gamer/files/1.4-multilib.patch b/sci-libs/gamer/files/1.4-multilib.patch
new file mode 100644
index 000000000000..3ebc8dcd7aab
--- /dev/null
+++ b/sci-libs/gamer/files/1.4-multilib.patch
@@ -0,0 +1,26 @@
+diff --git a/src/aaa_lib/Makefile.am b/src/aaa_lib/Makefile.am
+index de1d7c3..b2420c8 100644
+--- a/src/aaa_lib/Makefile.am
++++ b/src/aaa_lib/Makefile.am
+@@ -35,18 +35,17 @@ LIBTETGEN = libtetgen.la
+ #LIBTETGEN =
+ #endif
+
+-libdir = ${prefix}/lib
+ lib_LTLIBRARIES = libgamer.la ${LIBTRIANGLE} ${LIBTETGEN}
+
+ libgamer_la_SOURCES =
+-libgamer_la_LIBADD = ${BASE_LIBS} ${BIOM_LIBS}
++libgamer_la_LIBADD = ${BASE_LIBS} ${BIOM_LIBS} -lm -lstdc++ ../tetgen/libtetgen.la
+ libgamer_la_LDFLAGS = -version-info ${FETK_VERSION}
+
+ libtriangle_la_SOURCES =
+-libtriangle_la_LIBADD = ${TRIANGLE_LIBS}
++libtriangle_la_LIBADD = ${TRIANGLE_LIBS} -lm
+ libtriangle_la_LDFLAGS = -version-info ${FETK_VERSION}
+
+ libtetgen_la_SOURCES =
+-libtetgen_la_LIBADD = ${TETGEN_LIBS}
++libtetgen_la_LIBADD = ${TETGEN_LIBS} -lm -lstdc++
+ libtetgen_la_LDFLAGS = -version-info ${FETK_VERSION}
+
diff --git a/sci-libs/gamer/files/1.5-underlinking.patch b/sci-libs/gamer/files/1.5-underlinking.patch
new file mode 100644
index 000000000000..6cd8c93e49f6
--- /dev/null
+++ b/sci-libs/gamer/files/1.5-underlinking.patch
@@ -0,0 +1,42 @@
+ src/aaa_lib/Makefile.am | 17 +++--------------
+ 1 files changed, 3 insertions(+), 14 deletions(-)
+
+diff --git a/src/aaa_lib/Makefile.am b/src/aaa_lib/Makefile.am
+index de1d7c3..83e2e5c 100644
+--- a/src/aaa_lib/Makefile.am
++++ b/src/aaa_lib/Makefile.am
+@@ -22,31 +22,20 @@ BASE_LIBS = ../base/libbase.la
+ BIOM_LIBS = ../biom/libbiom.la
+
+ TRIANGLE_LIBS = ../triangle/libtriangle.la
+-#if BUILD_TRIANGLE
+-LIBTRIANGLE = libtriangle.la
+-#else
+-#LIBTRIANGLE =
+-#endif
+
+ TETGEN_LIBS = ../tetgen/libtetgen.la
+-#if BUILD_TETGEN
+-LIBTETGEN = libtetgen.la
+-#else
+-#LIBTETGEN =
+-#endif
+
+-libdir = ${prefix}/lib
+ lib_LTLIBRARIES = libgamer.la ${LIBTRIANGLE} ${LIBTETGEN}
+
+ libgamer_la_SOURCES =
+-libgamer_la_LIBADD = ${BASE_LIBS} ${BIOM_LIBS}
++libgamer_la_LIBADD = ${BASE_LIBS} ${BIOM_LIBS} -lm -lstdc++ ${LIBTETGEN}
+ libgamer_la_LDFLAGS = -version-info ${FETK_VERSION}
+
+ libtriangle_la_SOURCES =
+-libtriangle_la_LIBADD = ${TRIANGLE_LIBS}
++libtriangle_la_LIBADD = ${TRIANGLE_LIBS} -lm
+ libtriangle_la_LDFLAGS = -version-info ${FETK_VERSION}
+
+ libtetgen_la_SOURCES =
+-libtetgen_la_LIBADD = ${TETGEN_LIBS}
++libtetgen_la_LIBADD = ${TETGEN_LIBS} -lm -lstdc++
+ libtetgen_la_LDFLAGS = -version-info ${FETK_VERSION}
+