summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2016-06-28 18:26:03 +0000
committerSven Wegener <swegener@gentoo.org>2016-07-18 20:39:24 +0000
commit8091a2d1eef7b014d2aaee3d2c6906397bc970d0 (patch)
tree83887b73637d6ac8217bce3a8aa1a630a6f489d3 /sci-libs/gdal
parentapp-admin/eclean-kernel: Bump to 1.99.0 pre-release (diff)
downloadgentoo-8091a2d1eef7b014d2aaee3d2c6906397bc970d0.tar.gz
gentoo-8091a2d1eef7b014d2aaee3d2c6906397bc970d0.tar.bz2
gentoo-8091a2d1eef7b014d2aaee3d2c6906397bc970d0.zip
sci-libs/gdal: Fix building with >=swig-3.0.6
Package-Manager: portage-2.2.28 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/files/gdal-1.11-swig-3.0.6.patch22
-rw-r--r--sci-libs/gdal/gdal-1.11.1-r3.ebuild5
-rw-r--r--sci-libs/gdal/gdal-1.11.2.ebuild5
3 files changed, 30 insertions, 2 deletions
diff --git a/sci-libs/gdal/files/gdal-1.11-swig-3.0.6.patch b/sci-libs/gdal/files/gdal-1.11-swig-3.0.6.patch
new file mode 100644
index 000000000000..4f4e80b84f9b
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.11-swig-3.0.6.patch
@@ -0,0 +1,22 @@
+--- gdal/swig/include/python/ogr_python.i
++++ gdal/swig/include/python/ogr_python.i
+@@ -67,7 +67,7 @@
+ def __getitem__(self, value):
+ """Support dictionary, list, and slice -like access to the datasource.
+-ds[0] would return the first layer on the datasource.
+-ds['aname'] would return the layer named "aname".
+-ds[0:4] would return a list of the first four layers."""
++ ds[0] would return the first layer on the datasource.
++ ds['aname'] would return the layer named "aname".
++ ds[0:4] would return a list of the first four layers."""
+ if isinstance(value, slice):
+ output = []
+@@ -135,6 +135,6 @@
+ def __getitem__(self, value):
+ """Support list and slice -like access to the layer.
+-layer[0] would return the first feature on the layer.
+-layer[0:4] would return a list of the first four features."""
++ layer[0] would return the first feature on the layer.
++ layer[0:4] would return a list of the first four features."""
+ if isinstance(value, slice):
+ import sys
diff --git a/sci-libs/gdal/gdal-1.11.1-r3.ebuild b/sci-libs/gdal/gdal-1.11.1-r3.ebuild
index e244d2713fc8..8a55b2f89aae 100644
--- a/sci-libs/gdal/gdal-1.11.1-r3.ebuild
+++ b/sci-libs/gdal/gdal-1.11.1-r3.ebuild
@@ -59,7 +59,7 @@ RDEPEND="
xls? ( dev-libs/freexl )
"
-SWIG_DEP=">=dev-lang/swig-2.0.2 <=dev-lang/swig-3.0.4"
+SWIG_DEP=">=dev-lang/swig-2.0.2"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
java? ( >=virtual/jdk-1.6 )
@@ -122,6 +122,9 @@ src_prepare() {
# Fix swig-3.0.3 problem (bug #534168)
epatch "${FILESDIR}"/${PN}-1.11.1-swig-3.0.3.patch
+ # Fix swig-3.0.6 problem, https://trac.osgeo.org/gdal/ticket/6045
+ epatch "${FILESDIR}"/${PN}-1.11-swig-3.0.6.patch
+
# bug 540132
epatch "${FILESDIR}"/${PN}-1.11.1-poppler-0.31.0-support.patch
diff --git a/sci-libs/gdal/gdal-1.11.2.ebuild b/sci-libs/gdal/gdal-1.11.2.ebuild
index 3a3e22fbaab8..985f716e6f1d 100644
--- a/sci-libs/gdal/gdal-1.11.2.ebuild
+++ b/sci-libs/gdal/gdal-1.11.2.ebuild
@@ -59,7 +59,7 @@ RDEPEND="
xls? ( dev-libs/freexl )
"
-SWIG_DEP=">=dev-lang/swig-2.0.2 <=dev-lang/swig-3.0.4"
+SWIG_DEP=">=dev-lang/swig-2.0.2"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
java? ( >=virtual/jdk-1.6 )
@@ -122,6 +122,9 @@ src_prepare() {
# bug 540132
epatch "${FILESDIR}"/${PN}-1.11.1-poppler-0.31.0-support.patch
+ # Fix swig-3.0.6 problem, https://trac.osgeo.org/gdal/ticket/6045
+ epatch "${FILESDIR}"/${PN}-1.11-swig-3.0.6.patch
+
tc-export AR RANLIB
eautoreconf