summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:22 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:22 +0200
commit0307b6b0f8a436273160af04404a38fd31ef89d1 (patch)
treec6e3bf97ee377266d7c869d415167ee491a21436 /sci-libs/ginkgo
parentsci-libs/ceres-solver: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-0307b6b0f8a436273160af04404a38fd31ef89d1.tar.gz
gentoo-0307b6b0f8a436273160af04404a38fd31ef89d1.tar.bz2
gentoo-0307b6b0f8a436273160af04404a38fd31ef89d1.zip
sci-libs/ginkgo: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/ginkgo')
-rw-r--r--sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild b/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
index 5092a73a706d..abd270c911c4 100644
--- a/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
+++ b/sci-libs/ginkgo/ginkgo-1.4.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,11 +26,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && \
- use openmp && ! tc-has-openmp ; then
- die "Need an OpenMP capable compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {