summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-08-20 21:50:09 +0000
committerMichael Orlitzky <mjo@gentoo.org>2024-08-20 22:00:13 +0000
commita1801197d0309661e71f1f6c287fd48e33db1c94 (patch)
tree798f5a76d0ed47e9ed2e09ee1da862203d35bec9 /sci-libs/iml
parentdev-python/conway-polynomials: keyword 0.10 for ~riscv (diff)
downloadgentoo-a1801197d0309661e71f1f6c287fd48e33db1c94.tar.gz
gentoo-a1801197d0309661e71f1f6c287fd48e33db1c94.tar.bz2
gentoo-a1801197d0309661e71f1f6c287fd48e33db1c94.zip
sci-libs/iml: EAPI 7 -> 8, kill .la files, keyword ~riscv
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/iml')
-rw-r--r--sci-libs/iml/iml-1.0.5-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/iml/iml-1.0.5-r1.ebuild b/sci-libs/iml/iml-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..f967cdfd1ab6
--- /dev/null
+++ b/sci-libs/iml/iml-1.0.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Integer Matrix Library"
+HOMEPAGE="https://www.cs.uwaterloo.ca/~astorjoh/iml.html"
+SRC_URI="https://www.cs.uwaterloo.ca/~astorjoh/${P}.tar.bz2"
+
+# COPYING is GPL-2, but the files under src/ all have a BSD header
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="virtual/cblas"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.4-use-any-cblas-implementation.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-default="${EPREFIX}"/usr \
+ --enable-shared \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}