summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-02 04:24:08 +0000
committerSam James <sam@gentoo.org>2022-03-02 04:24:08 +0000
commit81e3309856b2cd2cea8ef4a7c6809fbfbf0ae9ea (patch)
tree2139b8b8460caa75b6f3f5ee3af3776d9e1cde36 /sci-libs/itpp/itpp-4.3.1-r2.ebuild
parentapp-emulation/wine-vanilla: drop IUSE="elibc_glibc" (diff)
downloadgentoo-81e3309856b2cd2cea8ef4a7c6809fbfbf0ae9ea.tar.gz
gentoo-81e3309856b2cd2cea8ef4a7c6809fbfbf0ae9ea.tar.bz2
gentoo-81e3309856b2cd2cea8ef4a7c6809fbfbf0ae9ea.zip
sci-libs/itpp: update EAPI 6 -> 8
Bug: https://bugs.gentoo.org/834293 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/itpp/itpp-4.3.1-r2.ebuild')
-rw-r--r--sci-libs/itpp/itpp-4.3.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/itpp/itpp-4.3.1-r2.ebuild b/sci-libs/itpp/itpp-4.3.1-r2.ebuild
new file mode 100644
index 000000000000..545434c5022b
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.3.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="sci-libs/fftw:3.0=
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base
+ )"
+
+DOCS=( ChangeLog NEWS AUTHORS README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.1-use-GNUInstallDirs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLA_VENDOR=Generic
+ -DHTML_DOCS=$(usex doc)
+ )
+
+ cmake_src_configure
+}