summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/lemon/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/lemon/files')
-rw-r--r--sci-libs/lemon/files/lemon-1.3-as-needed.patch47
-rw-r--r--sci-libs/lemon/files/lemon-1.3-multilib.patch18
2 files changed, 65 insertions, 0 deletions
diff --git a/sci-libs/lemon/files/lemon-1.3-as-needed.patch b/sci-libs/lemon/files/lemon-1.3-as-needed.patch
new file mode 100644
index 000000000000..ab205e69a4fa
--- /dev/null
+++ b/sci-libs/lemon/files/lemon-1.3-as-needed.patch
@@ -0,0 +1,47 @@
+ CMakeLists.txt | 4 ++++
+ lemon/CMakeLists.txt | 2 ++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b06e5c7..fa68aa8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -84,21 +84,25 @@ IF(GLPK_FOUND)
+ SET(LEMON_HAVE_LP TRUE)
+ SET(LEMON_HAVE_MIP TRUE)
+ SET(LEMON_HAVE_GLPK TRUE)
++ SET(LEMON_LP_LIBRARIES ${LEMON_LP_LIBRARIES} ${GLPK_LIBRARIES})
+ ENDIF(GLPK_FOUND)
+ IF(ILOG_FOUND)
+ SET(LEMON_HAVE_LP TRUE)
+ SET(LEMON_HAVE_MIP TRUE)
+ SET(LEMON_HAVE_CPLEX TRUE)
++ SET(LEMON_LP_LIBRARIES ${LEMON_LP_LIBRARIES} ${ILOG_LIBRARIES})
+ ENDIF(ILOG_FOUND)
+ IF(COIN_FOUND)
+ SET(LEMON_HAVE_LP TRUE)
+ SET(LEMON_HAVE_MIP TRUE)
+ SET(LEMON_HAVE_CLP TRUE)
+ SET(LEMON_HAVE_CBC TRUE)
++ SET(LEMON_LP_LIBRARIES ${LEMON_LP_LIBRARIES} ${COIN_LIBRARIES})
+ ENDIF(COIN_FOUND)
+ IF(SOPLEX_FOUND)
+ SET(LEMON_HAVE_LP TRUE)
+ SET(LEMON_HAVE_SOPLEX TRUE)
++ SET(LEMON_LP_LIBRARIES ${LEMON_LP_LIBRARIES} ${COIN_LIBRARIES})
+ ENDIF(SOPLEX_FOUND)
+
+ IF(ILOG_FOUND)
+diff --git a/lemon/CMakeLists.txt b/lemon/CMakeLists.txt
+index 8011833..2487345 100644
+--- a/lemon/CMakeLists.txt
++++ b/lemon/CMakeLists.txt
+@@ -59,6 +59,8 @@ IF(UNIX)
+ SET_TARGET_PROPERTIES(lemon PROPERTIES OUTPUT_NAME emon)
+ ENDIF()
+
++TARGET_LINK_LIBRARIES(lemon ${LEMON_LP_LIBRARIES})
++
+ INSTALL(
+ TARGETS lemon
+ ARCHIVE DESTINATION lib
diff --git a/sci-libs/lemon/files/lemon-1.3-multilib.patch b/sci-libs/lemon/files/lemon-1.3-multilib.patch
new file mode 100644
index 000000000000..ee578d4a0f6a
--- /dev/null
+++ b/sci-libs/lemon/files/lemon-1.3-multilib.patch
@@ -0,0 +1,18 @@
+ lemon/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lemon/CMakeLists.txt b/lemon/CMakeLists.txt
+index 8011833..0209acf 100644
+--- a/lemon/CMakeLists.txt
++++ b/lemon/CMakeLists.txt
+@@ -61,8 +61,8 @@ ENDIF()
+
+ INSTALL(
+ TARGETS lemon
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION lib${LIB_SUFFIX}
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ COMPONENT library
+ )
+