summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-25 13:04:42 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-25 13:04:42 +0200
commite0fb72ef6cf767a0218b9f23ea0b848592878e24 (patch)
tree295b10c8922b56240af02b75de65013016f457cc /sci-libs/libsvm
parentapp-emacs/pymacs: Drop dependency on Python 2. (diff)
downloadgentoo-e0fb72ef6cf767a0218b9f23ea0b848592878e24.tar.gz
gentoo-e0fb72ef6cf767a0218b9f23ea0b848592878e24.tar.bz2
gentoo-e0fb72ef6cf767a0218b9f23ea0b848592878e24.zip
sci-libs/libsvm: Remove old 3.22
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/libsvm')
-rw-r--r--sci-libs/libsvm/Manifest1
-rw-r--r--sci-libs/libsvm/libsvm-3.22.ebuild117
2 files changed, 0 insertions, 118 deletions
diff --git a/sci-libs/libsvm/Manifest b/sci-libs/libsvm/Manifest
index 4d7184371f79..b4b1cfca5372 100644
--- a/sci-libs/libsvm/Manifest
+++ b/sci-libs/libsvm/Manifest
@@ -1,2 +1 @@
-DIST libsvm-3.22.tar.gz 850563 BLAKE2B 824451dd2cafb7f2546d510d2c516dee67c27e586d5b16557a3c23e0c372cd577af5a322e24f70df6cda66e0a58f2e4d70017e6155a1d211ad3c728f840bfa2b SHA512 80a22fd2c2a82f70b8279fa5d8c5a2838b10ee439cf6d725816d608f8e45990ba1780ae6750cad78b25c1c18daf2c2315b342b9e329affbd5729d6fd7da87f7a
DIST libsvm-3.24.tar.gz 876441 BLAKE2B 6781804ba9706de5ad363bcbda20f2ec181cc4ee9613c9e7429f03872f7a03b04859df2ec00692d9de3ea237d1e478435a4d4db3ce7e5292689a2eab26a1fe46 SHA512 ff3c39bc84291bfb707151d7b8b6fb2eece937afa769cb8ee579d00ee4c30e943d476cd7bb18851d482c9bed89cf94fb3fd8abca4d47253360e12e9406f2f24b
diff --git a/sci-libs/libsvm/libsvm-3.22.ebuild b/sci-libs/libsvm/libsvm-3.22.ebuild
deleted file mode 100644
index a84738b3fae5..000000000000
--- a/sci-libs/libsvm/libsvm-3.22.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit flag-o-matic java-pkg-opt-2 python-r1 toolchain-funcs
-
-DESCRIPTION="Library for Support Vector Machines"
-HOMEPAGE="https://www.csie.ntu.edu.tw/~cjlin/libsvm/"
-SRC_URI="https://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="java openmp python tools"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
- java? ( >=virtual/jdk-1.4 )
- python? ( ${PYTHON_DEPS} )"
-RDEPEND="
- java? ( >=virtual/jre-1.4 )
- python? ( ${PYTHON_DEPS} )
- tools? ( sci-visualization/gnuplot )"
-
-PATCHES=(
- "${FILESDIR}/3.11-openmp.patch"
- "${FILESDIR}/3.14-makefile.patch"
-)
-
-pkg_setup() {
- if use openmp; then
- if ! tc-has-openmp; then
- ewarn "OpenMP is not supported by your currently selected compiler"
-
- if tc-is-clang; then
- ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
- ewarn "which you will need to build ${CATEGORY}/${PN} for USE=\"openmp\""
- fi
-
- die "need openmp capable compiler"
- fi
-
- append-cflags -fopenmp
- append-cxxflags -fopenmp
- append-cppflags -DOPENMP
- fi
-}
-
-src_prepare() {
- default
-
- sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
- || die "Failed to fix paths in python files"
- sed -i -e "s|./grid.py|${EPREFIX}/usr/bin/svm-grid|g" tools/*.py \
- || die "Failed to fix paths for svm-grid"
- sed -i -e 's/grid.py/svm-grid/g' tools/grid.py \
- || die "Failed to rename grid.py to svm-grid"
-
- if use java; then
- local JAVAC_FLAGS="$(java-pkg_javac-args)"
- sed -i \
- -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
- java/Makefile || die "Failed to fix java makefile"
- fi
- tc-export CXX CC
-}
-
-src_compile() {
- default
- use java && emake -C java
-}
-
-src_install() {
- dobin svm-train svm-predict svm-scale
- dolib.so *.so*
- doheader svm.h
-
- DOCS=( README )
-
- if use tools; then
- local t
- for t in tools/*.py; do
- python_foreach_impl python_newscript ${t} svm-$(basename ${t} .py)
- done
-
- mv tools/README{,.tools} || die
- DOCS+=( tools/README.tools )
-
- insinto /usr/share/doc/${PF}/examples
- docompress -x /usr/share/doc/${PF}/examples
- doins heart_scale
- doins -r svm-toy
- fi
-
- if use python ; then
- installation() {
- touch python/__init__.py || die
- python_moduleinto libsvm
- python_domodule python/*.py
- }
- python_foreach_impl installation
-
- mv python/README{,.python} || die
- DOCS+=( python/README.python )
- fi
-
- HTML_DOCS=( FAQ.html )
- if use java; then
- java-pkg_dojar java/libsvm.jar
- HTML_DOCS+=( java/test_applet.html )
- fi
-
- einstalldocs
-}