summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-05-29 16:28:44 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-05-29 16:28:58 +0200
commit776a9dcc768dddedf0731f964eb64d7cded4cadd (patch)
treeb65687ec5bc059fd91bde044fe19c26c8882f669 /sci-libs/linux-gpib/linux-gpib-4.0.3-r1.ebuild
parentprofiles: Mask php bindings of Linux-GPIB (diff)
downloadgentoo-776a9dcc768dddedf0731f964eb64d7cded4cadd.tar.gz
gentoo-776a9dcc768dddedf0731f964eb64d7cded4cadd.tar.bz2
gentoo-776a9dcc768dddedf0731f964eb64d7cded4cadd.zip
sci-libs/linux-gpib: Add patch for kernel 4.11 and check VMAP_STACK
https://sourceforge.net/p/linux-gpib/bugs/61/ https://sourceforge.net/p/linux-gpib/bugs/62/ Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-libs/linux-gpib/linux-gpib-4.0.3-r1.ebuild')
-rw-r--r--sci-libs/linux-gpib/linux-gpib-4.0.3-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-libs/linux-gpib/linux-gpib-4.0.3-r1.ebuild b/sci-libs/linux-gpib/linux-gpib-4.0.3-r1.ebuild
index d7b9bcef43f7..8e7b27438b4f 100644
--- a/sci-libs/linux-gpib/linux-gpib-4.0.3-r1.ebuild
+++ b/sci-libs/linux-gpib/linux-gpib-4.0.3-r1.ebuild
@@ -5,11 +5,13 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit readme.gentoo-r1 versionator eutils linux-mod autotools perl-functions python-single-r1 toolchain-funcs udev user
+inherit linux-info readme.gentoo-r1 versionator eutils linux-mod autotools perl-functions python-single-r1 toolchain-funcs udev user
+
+MY_PV=${PV/_/}
DESCRIPTION="Kernel module and driver library for GPIB (IEEE 488.2) hardware"
HOMEPAGE="http://linux-gpib.sourceforge.net/"
-SRC_URI="mirror://sourceforge/linux-gpib/${P}.tar.gz
+SRC_URI="mirror://sourceforge/linux-gpib/${PN}-${MY_PV}.tar.gz
firmware? ( http://linux-gpib.sourceforge.net/firmware/gpib_firmware-2006-11-12.tar.gz )
"
@@ -39,9 +41,13 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.0.3-reallydie.patch
)
+S=${WORKDIR}/${PN}-${MY_PV}
+
pkg_setup () {
use perl && perl_set_version
use python && python_setup
+
+ CONFIG_CHECK="!VMAP_STACK"
linux-mod_pkg_setup
if kernel_is -lt 2 6 8; then
@@ -56,6 +62,7 @@ pkg_setup () {
src_prepare () {
default
+ kernel_is ge 4 11 0 && eapply "${FILESDIR}"/${PN}-4.0.4_rc2-kernel-4.11.0.patch
eautoreconf
}