summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-12-06 11:33:59 -0600
committerMatthias Maier <tamiko@gentoo.org>2023-12-06 22:28:32 -0600
commit2ecd1110e3b70f751b8763a5146916e704adc926 (patch)
tree25ccb9af16837ce1df26dc8323d18f7047fc9f79 /sci-libs/trilinos
parentsci-libs/trilinos: add 15.0.0 (diff)
downloadgentoo-2ecd1110e3b70f751b8763a5146916e704adc926.tar.gz
gentoo-2ecd1110e3b70f751b8763a5146916e704adc926.tar.bz2
gentoo-2ecd1110e3b70f751b8763a5146916e704adc926.zip
sci-libs/trilinos: various QA fixes
- remove obsolete configuration options - filter lto flags - disable RPATH handling - reenable SEACAS Closes: https://bugs.gentoo.org/851489 Closes: https://bugs.gentoo.org/862987 Closes: https://bugs.gentoo.org/823434 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/trilinos')
-rw-r--r--sci-libs/trilinos/trilinos-14.4.0.ebuild11
-rw-r--r--sci-libs/trilinos/trilinos-15.0.0.ebuild19
2 files changed, 11 insertions, 19 deletions
diff --git a/sci-libs/trilinos/trilinos-14.4.0.ebuild b/sci-libs/trilinos/trilinos-14.4.0.ebuild
index 8e143ef76619..709a6fdc1fe0 100644
--- a/sci-libs/trilinos/trilinos-14.4.0.ebuild
+++ b/sci-libs/trilinos/trilinos-14.4.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CMAKE_MAKEFILE_GENERATOR=emake
-inherit cmake toolchain-funcs
+inherit cmake flag-o-matic toolchain-funcs
DESCRIPTION="Scientific library collection for large scale problems"
HOMEPAGE="http://trilinos.sandia.gov/"
@@ -94,18 +94,21 @@ trilinos_conf() {
#
# The following packages are currently disabled:
-# - Adelus/Zadelus due to underlinkage.
-# - Moertel due to underlinkage
# - SEACAS is incompatible with netcdf, see
# https://github.com/trilinos/Trilinos/tree/master/packages/seacas#netcdf
#
src_configure() {
+ # Trilinos is a massive C++ project. Fixing all of the lto warnings and
+ # making safe for lto compilation/linking will be a massive
+ # undertaking. Thus, simply filter lto flags. bug #862987
+ filter-lto
+
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DCMAKE_INSTALL_PREFIX="${EPREFIX}"
+ -DCMAKE_SKIP_RPATH=ON
-DCMAKE_SKIP_INSTALL_RPATH=ON
- -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=OFF
-DTrilinos_INSTALL_INCLUDE_DIR="${EPREFIX}/usr/include/trilinos"
-DTrilinos_INSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)/trilinos"
-DTrilinos_ENABLE_ALL_PACKAGES="$(usex all-packages)"
diff --git a/sci-libs/trilinos/trilinos-15.0.0.ebuild b/sci-libs/trilinos/trilinos-15.0.0.ebuild
index 86d691392b39..2d104e3e9ce2 100644
--- a/sci-libs/trilinos/trilinos-15.0.0.ebuild
+++ b/sci-libs/trilinos/trilinos-15.0.0.ebuild
@@ -92,32 +92,21 @@ trilinos_conf() {
[[ -n ${dirs} ]] && mycmakeargs+=( "-D${2}_INCLUDE_DIRS=${dirs:1}" )
}
-#
-# The following packages are currently disabled:
-# - Adelus/Zadelus due to underlinkage.
-# - Moertel due to underlinkage
-# - SEACAS is incompatible with netcdf, see
-# https://github.com/trilinos/Trilinos/tree/master/packages/seacas#netcdf
-#
-
src_configure() {
- # Trilinos is a massive CPP project. Fixing all of the lto warnings and
- # making lto compilation/linking save will be a massive undertaking.
- # Thus, simply filter lto flags. bug #862987
+ # Trilinos is a massive C++ project. Fixing all of the lto warnings and
+ # making safe for lto compilation/linking will be a massive
+ # undertaking. Thus, simply filter lto flags. bug #862987
filter-lto
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DCMAKE_INSTALL_PREFIX="${EPREFIX}"
+ -DCMAKE_SKIP_RPATH=ON
-DCMAKE_SKIP_INSTALL_RPATH=ON
- -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=OFF
-DTrilinos_INSTALL_INCLUDE_DIR="${EPREFIX}/usr/include/trilinos"
-DTrilinos_INSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)/trilinos"
-DTrilinos_ENABLE_ALL_PACKAGES="$(usex all-packages)"
- -DTrilinos_ENABLE_Adelus=OFF
- -DTrilinos_ENABLE_Moertel=OFF
-DTrilinos_ENABLE_PyTrilinos=OFF
- -DTrilinos_ENABLE_SEACAS=OFF
-DTrilinos_ENABLE_Amesos=ON
-DTrilinos_ENABLE_AztecOO=ON
-DTrilinos_ENABLE_EpetraExt=ON