summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-05-01 09:45:17 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-05-01 11:47:27 -0500
commit5c9d6ce7a1706c381df35c68f28f56132b57c344 (patch)
tree51398b4784d8db9102f7cead5b65e2792888b3f8 /sci-libs/vtk
parentxfce-base/xfce4-panel: add dependency on gdbus-codegen (diff)
downloadgentoo-5c9d6ce7a1706c381df35c68f28f56132b57c344.tar.gz
gentoo-5c9d6ce7a1706c381df35c68f28f56132b57c344.tar.bz2
gentoo-5c9d6ce7a1706c381df35c68f28f56132b57c344.zip
sci-libs/vtk: fix compilation with openmpi-4
Closes: https://bugs.gentoo.org/683382 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/files/vtk-8.1.0-openmpi-4-compatibility.patch14
-rw-r--r--sci-libs/vtk/vtk-8.1.0-r6.ebuild6
2 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-8.1.0-openmpi-4-compatibility.patch b/sci-libs/vtk/files/vtk-8.1.0-openmpi-4-compatibility.patch
new file mode 100644
index 000000000000..267c1d91b0cb
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-8.1.0-openmpi-4-compatibility.patch
@@ -0,0 +1,14 @@
+diff --git a/ThirdParty/mpi4py/vtkmpi4py/src/lib-mpi/config/openmpi.h b/ThirdParty/mpi4py/vtkmpi4py/src/lib-mpi/config/openmpi.h
+index 3173831..e8ee74b 100644
+--- a/ThirdParty/mpi4py/vtkmpi4py/src/lib-mpi/config/openmpi.h
++++ b/ThirdParty/mpi4py/vtkmpi4py/src/lib-mpi/config/openmpi.h
+@@ -141,4 +141,9 @@
+
+ #endif
+
++ #if OMPI_NUMVERSION >= 40000
++ #undef PyMPI_HAVE_MPI_LB
++ #undef PyMPI_HAVE_MPI_UB
++ #endif /* OMPI >= 4.0.0 */
++
+ #endif /* !PyMPI_CONFIG_OPENMPI_H */
diff --git a/sci-libs/vtk/vtk-8.1.0-r6.ebuild b/sci-libs/vtk/vtk-8.1.0-r6.ebuild
index 06e69225f0fb..9e5bc9d717cf 100644
--- a/sci-libs/vtk/vtk-8.1.0-r6.ebuild
+++ b/sci-libs/vtk/vtk-8.1.0-r6.ebuild
@@ -116,6 +116,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/VTK-${PV}
+PATCHES=(
+ "${FILESDIR}"/vtk-8.1.0-openmpi-4-compatibility.patch
+)
+
RESTRICT="test"
pkg_setup() {
@@ -125,6 +129,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
local x
# missing: VPIC freerange libproj4 mrmpi sqlite utf8 verdict xmdf2 xmdf3
for x in constantly expat freetype hdf5 hyperlink incremental jpeg jsoncpp libharu libxml2 lz4 netcdf oggtheora png tiff Twisted txaio zlib ZopeInterface; do