summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-12-17 20:55:20 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-12-17 20:55:36 +0100
commit005d7ef8795823df32147f3f0a0a0733195d6f48 (patch)
tree4e36ec368e6f2d1e723eb13313f9bae4a0ac58f9 /sci-libs
parentgames-engines/devilutionx: set RESTRICT="bindist mirror" (diff)
downloadgentoo-005d7ef8795823df32147f3f0a0a0733195d6f48.tar.gz
gentoo-005d7ef8795823df32147f3f0a0a0733195d6f48.tar.bz2
gentoo-005d7ef8795823df32147f3f0a0a0733195d6f48.zip
sci-libs/branca: add 0.8.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/branca/Manifest1
-rw-r--r--sci-libs/branca/branca-0.8.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/branca/Manifest b/sci-libs/branca/Manifest
index 2ab1e1a916e5..8f9f5c985cde 100644
--- a/sci-libs/branca/Manifest
+++ b/sci-libs/branca/Manifest
@@ -1 +1,2 @@
DIST branca-0.8.0.tar.gz 43075 BLAKE2B 46779d59ca981c1f6e76193b1776c77a7c455b67d93115027b17f96b8c4df737502dc32feb6ce242e0f2fec9ed4541ed79c6856e85d740dec40d092000873b32 SHA512 b5e8ac51a5d1b70ee72066ee16c9fc8d37623ca807c67cf0f5a2daba37f901ecd9eb81b03857c222ace1f36fb71a9a348aae7079deccf657eaabcc1dc6b64158
+DIST branca-0.8.1.tar.gz 43109 BLAKE2B e2b123be2d9cb2192f9cdd93842249b0f30c8edf85b401b4a48e1e8e4b4a60c689fe74278faabefa0fdba314f484e81b0f4e0a70e37397c827d3f0b94fe84768 SHA512 70b5a8f7da69dfdf9195d3b9f7e70510a1b6cb199224b8583190aa20bb1699bed9b77c31d34dd365dbae5ef0c32f67baaaf20a2546c11203b7140c3d80f3dd2e
diff --git a/sci-libs/branca/branca-0.8.1.ebuild b/sci-libs/branca/branca-0.8.1.ebuild
new file mode 100644
index 000000000000..3a77c1baafb4
--- /dev/null
+++ b/sci-libs/branca/branca-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="spinoff from folium, host the non-map-specific features"
+HOMEPAGE="https://github.com/python-visualization/branca"
+SRC_URI="https://github.com/python-visualization/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jinja2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm
+ test? (
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs/source \
+ dev-python/nbsphinx
+
+python_test() {
+ epytest -m 'not headless'
+}