summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-11-12 16:01:26 -0800
committerDavid Seifert <soap@gentoo.org>2022-11-12 16:01:26 -0800
commit0a8e8238cc3b75cbbfa96659e66b0ae2a7bab0ac (patch)
tree4f2aeb1ac90408e1a1f8b236938365462c2332e6 /sci-libs
parentsci-libs/pcl: fix several issues (diff)
downloadgentoo-0a8e8238cc3b75cbbfa96659e66b0ae2a7bab0ac.tar.gz
gentoo-0a8e8238cc3b75cbbfa96659e66b0ae2a7bab0ac.tar.bz2
gentoo-0a8e8238cc3b75cbbfa96659e66b0ae2a7bab0ac.zip
sci-libs/pcl: port changes from sci-libs/pcl-1.12.1-r1
Closes: https://github.com/gentoo/gentoo/pull/27977 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild36
1 files changed, 30 insertions, 6 deletions
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
index 1edbb0cd7140..a1c4d5880153 100644
--- a/sci-libs/pcl/pcl-9999.ebuild
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
fi
-inherit ${SCM} cmake multilib
+inherit ${SCM} cmake cuda
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
@@ -24,7 +24,8 @@ DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
SLOT="0/1.12"
IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 usb vtk cpu_flags_x86_sse test tutorials"
-RESTRICT="!test? ( test )"
+# tests need the gtest sources to be available at build time
+RESTRICT="test"
RDEPEND="
>=sci-libs/flann-1.7.1
@@ -48,11 +49,17 @@ RDEPEND="
"
DEPEND="${RDEPEND}
!!dev-cpp/metslib
- test? ( >=dev-cpp/gtest-1.6.0 )
"
BDEPEND="
- doc? ( app-doc/doxygen )
- tutorials? ( dev-python/sphinx dev-python/sphinxcontrib-doxylink )
+ doc? (
+ app-doc/doxygen[dot]
+ virtual/latex-base
+ )
+ tutorials? (
+ dev-python/sphinx
+ dev-python/sphinx_rtd_theme
+ dev-python/sphinxcontrib-doxylink
+ )
virtual/pkgconfig"
REQUIRED_USE="
@@ -61,9 +68,25 @@ REQUIRED_USE="
tutorials? ( doc )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12.1-allow-configuration-of-install-dirs.patch
+ "${FILESDIR}"/${PN}-1.12.1-fix-hardcoded-relative-directory-of-the-installed-cmake-files.patch
+)
+
+src_prepare() {
+ if use cuda; then
+ cuda_src_prepare
+ cuda_add_sandbox -w
+ fi
+
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
+ "-DDOC_INSTALL_DIR=share/doc/${PF}"
"-DLIB_INSTALL_DIR=$(get_libdir)"
+ "-DPCLCONFIG_INSTALL_DIR=share/cmake/${PN}-$(ver_cut 1-2)"
"-DWITH_CUDA=$(usex cuda TRUE FALSE)"
"-DWITH_LIBUSB=$(usex usb TRUE FALSE)"
"-DWITH_OPENGL=$(usex opengl TRUE FALSE)"
@@ -77,7 +100,8 @@ src_configure() {
"-DPCL_ENABLE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
"-DWITH_DOCS=$(usex doc TRUE FALSE)"
"-DWITH_TUTORIALS=$(usex tutorials TRUE FALSE)"
- "-DBUILD_TESTS=$(usex test TRUE FALSE)"
+ "-DBUILD_global_tests=FALSE"
)
+
cmake_src_configure
}