summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-10 10:55:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-10 11:32:42 +0200
commit287f462eba67dec7036cd51c4372896144219184 (patch)
tree398b717f3536d5f8c31316f8d9c3c2a00e3559f3 /sci-libs
parentsci-libs/rtree: Add python@ as co-maintainer (diff)
downloadgentoo-287f462eba67dec7036cd51c4372896144219184.tar.gz
gentoo-287f462eba67dec7036cd51c4372896144219184.tar.bz2
gentoo-287f462eba67dec7036cd51c4372896144219184.zip
Move {sci-libs → dev-python}/rtree
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rtree/Manifest2
-rw-r--r--sci-libs/rtree/metadata.xml25
-rw-r--r--sci-libs/rtree/rtree-1.0.0.ebuild30
-rw-r--r--sci-libs/rtree/rtree-1.3.0.ebuild36
4 files changed, 0 insertions, 93 deletions
diff --git a/sci-libs/rtree/Manifest b/sci-libs/rtree/Manifest
deleted file mode 100644
index 0fac7140604c..000000000000
--- a/sci-libs/rtree/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST Rtree-1.0.0.tar.gz 48837 BLAKE2B 60e516155e7e48158494b7ea4720dc71ece2111fb94e320976a6dd691d2458b8586c2bf8109a37d86db211ac342d77877b435bdb54627a94c898642e8520a071 SHA512 9a414cd65b27ba35313dd7185dece83f5d7235867f6f0c72c2902d7ffd72808138dbf30d8fe11c8bbf0ec463072e5f6112d75b5fdd5a1dab7720c56d3632d576
-DIST rtree-1.3.0.tar.gz 48190 BLAKE2B 1a9ed3617ca14e3a88e5800e871e3d3edd58bc31d5dcad3c30a4a3a51b44678beacfddc1c72cbd984139e8e9acfffda45cc478857dacba5b44e7775f29ef890f SHA512 28810b769d90914e5aea9ea0b7f27b946c8d19495965696624d4fdd94c6ad462eb5ce7004d2c41e017d14a69bc913f43fdcef5293abe8504b66d8dcd5f4955a2
diff --git a/sci-libs/rtree/metadata.xml b/sci-libs/rtree/metadata.xml
deleted file mode 100644
index eb60738f3714..000000000000
--- a/sci-libs/rtree/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>3dprint@gentoo.org</email>
- <name>Gentoo 3D Printer Project</name>
- </maintainer>
- <maintainer type="person">
- <email>andrewammerlaan@gentoo.org</email>
- <name>Andrew Ammerlaan</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
- Rtree is a ctypes Python wrapper of libspatialindex that provides a number of advanced spatial indexing
- features for the spatially curious Python user.
- </longdescription>
- <upstream>
- <bugs-to>https://github.com/Toblerity/rtree/issues</bugs-to>
- <remote-id type="github">Toblerity/rtree</remote-id>
- <remote-id type="pypi">Rtree</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/sci-libs/rtree/rtree-1.0.0.ebuild b/sci-libs/rtree/rtree-1.0.0.ebuild
deleted file mode 100644
index ffa872d759b3..000000000000
--- a/sci-libs/rtree/rtree-1.0.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN^}
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="R-Tree spatial index for Python GIS"
-HOMEPAGE="https://rtree.readthedocs.io"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- sci-libs/libspatialindex
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? ( dev-python/numpy[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
diff --git a/sci-libs/rtree/rtree-1.3.0.ebuild b/sci-libs/rtree/rtree-1.3.0.ebuild
deleted file mode 100644
index ff8999dbd054..000000000000
--- a/sci-libs/rtree/rtree-1.3.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..13} )
-DISTUTILS_USE_PEP517=setuptools
-PYPI_PN=${PN^}
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="R-Tree spatial index for Python GIS"
-HOMEPAGE="
- https://rtree.readthedocs.io/
- https://github.com/Toblerity/rtree/
- https://pypi.org/project/Rtree/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- sci-libs/libspatialindex
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/sphinx-issues
-distutils_enable_tests pytest