summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-12-09 09:33:29 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-12-09 09:33:29 +0100
commit54ba2742b754e3c25add341ace31836d699d2ae1 (patch)
tree36c7f857431df89deee6d1f6b78bd33c6acf70c1 /sci-libs
parentsci-libs/caffe2: save functorch.so for pytorch ebuild (diff)
downloadgentoo-54ba2742b754e3c25add341ace31836d699d2ae1.tar.gz
gentoo-54ba2742b754e3c25add341ace31836d699d2ae1.tar.bz2
gentoo-54ba2742b754e3c25add341ace31836d699d2ae1.zip
sci-libs/pytorch: fix functorch install, copying from caffe2
Closes: https://bugs.gentoo.org/943531 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pytorch/pytorch-2.5.1-r1.ebuild (renamed from sci-libs/pytorch/pytorch-2.5.1.ebuild)4
1 files changed, 4 insertions, 0 deletions
diff --git a/sci-libs/pytorch/pytorch-2.5.1.ebuild b/sci-libs/pytorch/pytorch-2.5.1-r1.ebuild
index 1a5e4c9a039f..e90ea383aecb 100644
--- a/sci-libs/pytorch/pytorch-2.5.1.ebuild
+++ b/sci-libs/pytorch/pytorch-2.5.1-r1.ebuild
@@ -23,6 +23,7 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="
${PYTHON_DEPS}
~sci-libs/caffe2-${PV}[${PYTHON_SINGLE_USEDEP}]
+ >=sci-libs/caffe2-2.5.1-r5
$(python_gen_cond_dep '
dev-python/typing-extensions[${PYTHON_USEDEP}]
dev-python/sympy[${PYTHON_USEDEP}]
@@ -46,6 +47,9 @@ src_prepare() {
|| die
distutils-r1_src_prepare
+ # Get object file from caffe2
+ cp /var/lib/caffe2/functorch.so functorch/functorch.so || die
+
hprefixify tools/setup_helpers/env.py
}