summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-03-16 22:41:56 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-03-16 22:42:11 -0400
commit84f79a6a4096a5e5135bd0965e8f696e18a699b7 (patch)
tree51aa703db7eb6beb1b455156f47c271fc1f0bdcc /sci-libs
parentapp-crypt/monkeysphere: drop 0.41 (diff)
downloadgentoo-84f79a6a4096a5e5135bd0965e8f696e18a699b7.tar.gz
gentoo-84f79a6a4096a5e5135bd0965e8f696e18a699b7.tar.bz2
gentoo-84f79a6a4096a5e5135bd0965e8f696e18a699b7.zip
sci-libs/m4rie: new revision with patch for libm linking.
Thanks to Alessandro Barbieri, François Bissey, and Martin Albrecht (upstream) for getting this fixed quickly. This commit adds an -r1 with the backported patch and a call to eautoreconf. Closes: https://bugs.gentoo.org/775311 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/m4rie/files/m4rie-20200115-link-libm.patch27
-rw-r--r--sci-libs/m4rie/m4rie-20200115-r1.ebuild (renamed from sci-libs/m4rie/m4rie-20200115.ebuild)12
2 files changed, 38 insertions, 1 deletions
diff --git a/sci-libs/m4rie/files/m4rie-20200115-link-libm.patch b/sci-libs/m4rie/files/m4rie-20200115-link-libm.patch
new file mode 100644
index 000000000000..d640b5085661
--- /dev/null
+++ b/sci-libs/m4rie/files/m4rie-20200115-link-libm.patch
@@ -0,0 +1,27 @@
+From afab50ea468b0b44be6e8584793c8ee98045f8f8 Mon Sep 17 00:00:00 2001
+From: "Martin R. Albrecht" <martinralbrecht@googlemail.com>
+Date: Fri, 12 Mar 2021 09:49:45 +0000
+Subject: [PATCH] we use sqrt() so link libm
+
+fixes #22
+---
+ configure.ac | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 1f19d49..71ed81c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,6 +18,9 @@ AC_PROG_CXX
+
+ AC_PROG_CC_C99()
+
++AC_SEARCH_LIBS([sqrt], [m], [], [
++ AC_MSG_ERROR([unable to find the sqrt() function])
++])
+
+ if test "$ac_cv_prog_cc_c99" = "no"; then
+ AC_MSG_ERROR([C99 support is required but not found.])
+--
+2.10.5
+
diff --git a/sci-libs/m4rie/m4rie-20200115.ebuild b/sci-libs/m4rie/m4rie-20200115-r1.ebuild
index 7030c39b71d0..48f2dd3f0476 100644
--- a/sci-libs/m4rie/m4rie-20200115.ebuild
+++ b/sci-libs/m4rie/m4rie-20200115-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Fast dense matrix arithmetic over GF(2^e) for 2 <= e <= 16"
HOMEPAGE="https://bitbucket.org/malb/m4rie/"
SRC_URI="https://bitbucket.org/malb/${PN}/downloads/${P}.tar.gz"
@@ -12,9 +14,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="debug static-libs"
-DEPEND=">=sci-libs/m4ri-20140914"
+DEPEND="sci-libs/m4ri"
RDEPEND="${DEPEND}"
+# Requires eautoreconf.
+PATCHES=( "${FILESDIR}/${P}-link-libm.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
# m4rie doesn't actually have any openmp code. The configure flag
# stems from a mistaken belief that it needs to be there to use the