summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/diagrtb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/diagrtb')
-rw-r--r--sci-mathematics/diagrtb/Manifest1
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild30
-rw-r--r--sci-mathematics/diagrtb/files/CMakeLists.txt13
-rw-r--r--sci-mathematics/diagrtb/metadata.xml27
4 files changed, 71 insertions, 0 deletions
diff --git a/sci-mathematics/diagrtb/Manifest b/sci-mathematics/diagrtb/Manifest
new file mode 100644
index 000000000000..0c9f34449ed1
--- /dev/null
+++ b/sci-mathematics/diagrtb/Manifest
@@ -0,0 +1 @@
+DIST diagrtb-2.64.tar.gz 2429842 SHA256 bbab6ed2f9eeae1c64d0d55764908748a5e321589df81c7d87647623950b7aa0
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
new file mode 100644
index 000000000000..1283039df7eb
--- /dev/null
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Calculation of some eigenvectors of a large real, symmetrical, matrix"
+HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
+SRC_URI="http://ecole.modelisation.free.fr/rtb2011.tar.gz -> ${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+RESTRICT="mirror bindist"
+
+S="${WORKDIR}"/Source_RTB2011
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use examples EXAMPLES)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-mathematics/diagrtb/files/CMakeLists.txt b/sci-mathematics/diagrtb/files/CMakeLists.txt
new file mode 100644
index 000000000000..d1eb6c62f09f
--- /dev/null
+++ b/sci-mathematics/diagrtb/files/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required (VERSION 2.6)
+project (DIAGRTB Fortran)
+
+option (EXAMPLES "Instal additional example files" OFF)
+
+add_executable(diagrtb diagrtb.f)
+
+install (TARGETS diagrtb DESTINATION bin)
+install (FILES diagrtb.README DESTINATION share/doc/diagrtb)
+
+if ( EXAMPLES )
+ install (DIRECTORY ../Try_RTB2011 DESTINATION share/diagrtb/examples)
+endif (EXAMPLES)
diff --git a/sci-mathematics/diagrtb/metadata.xml b/sci-mathematics/diagrtb/metadata.xml
new file mode 100644
index 000000000000..b2b6df7d599c
--- /dev/null
+++ b/sci-mathematics/diagrtb/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+A fortran program for the calculation of some eigenvectors of a large real,
+symmetrical, matrix.
+If the matrix was obtained, for instance, with the PDBMAT program, these
+eigenvectors correspond to the low-frequency normal modes (i.e., mostly
+those with a collective character) of the system. Note that in the case of
+proteins, low-frequency normal modes thus obtained are found to be very close
+to those obtained with standard, much more realistic (e.g., all atoms with
+empirical force fields), models.
+
+The method used rests upon the RTB approximation (standing for
+Rotations-Translations-of-Blocks). Within the frame of this approximation,
+blocks of n (n=1,2,...) consecutive monomers (amino-acid residues) are
+assumed to behave like rigid bodies.
+
+Requirements: a matrix in the "i j non-zero-ij-matrix-element" format.
+A file with the coordinates of the system, in the PDB or "x y z mass
+block-number" format.
+</longdescription>
+</pkgmetadata>