summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/kodkodi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/kodkodi')
-rw-r--r--sci-mathematics/kodkodi/Manifest1
-rw-r--r--sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild107
-rw-r--r--sci-mathematics/kodkodi/metadata.xml16
3 files changed, 124 insertions, 0 deletions
diff --git a/sci-mathematics/kodkodi/Manifest b/sci-mathematics/kodkodi/Manifest
new file mode 100644
index 000000000000..3d4329f7d2e4
--- /dev/null
+++ b/sci-mathematics/kodkodi/Manifest
@@ -0,0 +1 @@
+DIST kodkodi-1.5.2.tgz 2826648 SHA256 1518d75f3748aa7c791623ff1508b4202f14d744e13b9bd41abf575429caa2b7 SHA512 117e0f1b3e3ee88efb9a9e2f02e8a7ce82a3487528ad0476acf20fafd885d3d48c051bd4a8cb6aa5cda61f24dfa74159448b83398be4119e726e757f6ff3aad4 WHIRLPOOL f331b423b2ad430b59f425d799c3991dccf0e5e9018015f12c30be851f8254cf3b0e39da12fcfd07083813671316ecdcbfc70429742e89cf7b2b4093b773bb0b
diff --git a/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild b/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild
new file mode 100644
index 000000000000..a36c2daf0458
--- /dev/null
+++ b/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple multilib
+
+DESCRIPTION="A text front-end for the Kodkod Java library"
+HOMEPAGE="http://www21.in.tum.de/~blanchet/#software"
+SRC_URI="http://www21.in.tum.de/~blanchet/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="isabelle examples"
+
+COMMON_DEP="dev-java/antlr:3
+ =sci-mathematics/kodkod-1.5*:="
+RDEPEND="${COMMON_DEP}
+ isabelle? (
+ >=sci-mathematics/isabelle-2011-r1:=
+ )
+ >=virtual/jre-1.6"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.6
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="kodkod,antlr-3"
+
+java_prepare() {
+ sed -e 's@exec "$ISABELLE_TOOL" java $KODKODI_JAVA_OPT@java@' \
+ -i "${S}/bin/kodkodi" || die "Could not patch bin/kodkodi"
+ rm -f jar/*.jar || die "Could not rm jar files"
+}
+
+src_compile() {
+ JAVA_SRC_DIR="src"
+ TARGETDIR="/usr/share/${P}"
+ KODKOD_LIBDIR="/usr/"$(get_libdir)"/kodkod"
+
+ java-pkg-simple_src_compile
+
+ pushd "${S}/target/classes" > /dev/null || die
+ jar -uf "${S}"/${PN}.jar $(find -name '*.class') || die
+ popd > /dev/null
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc README HISTORY manual/${PN}.pdf LICENSES/Kodkodi
+ insinto ${TARGETDIR}
+ if use examples; then
+ doins -r examples
+ fi
+
+ if use isabelle; then
+ ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)" \
+ || die "isabelle getenv ISABELLE_HOME failed"
+ [[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
+ dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
+ cat <<- EOF >> "${S}/settings"
+ KODKODI="\$COMPONENT"
+ KODKODI_VERSION="${PV}"
+ KODKODI_PLATFORM=\$ISABELLE_PLATFORM
+ KODKODI_CLASSPATH="$(java-config --classpath=antlr:3):${ROOT}usr/share/${PN}-${SLOT}/lib/kodkodi.jar:$(java-config --classpath=kodkod)"
+ KODKODI_JAVA_LIBRARY_PATH="${KODKOD_LIBDIR}"
+ EOF
+ insinto "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
+ doins "${S}/settings"
+ dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/bin"
+ exeinto "${ISABELLE_HOME}/contrib/${PN}-${PV}/bin"
+ doexe bin/kodkodi
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [ -f "${ROOT}etc/isabelle/components" ]; then
+ if egrep "contrib/${PN}-[0-9.]*" "${ROOT}etc/isabelle/components"; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}etc/isabelle/components"
+ fi
+ cat <<- EOF >> "${ROOT}etc/isabelle/components"
+ contrib/${PN}-${PV}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [ ! -f "${ROOT}usr/bin/kodkodi" ]; then
+ if [ -f "${ROOT}etc/isabelle/components" ]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new kodkodi being installed during an upgrade.
+ sed -e "/contrib\/${PN}-${PV}/d" \
+ -i "${ROOT}etc/isabelle/components"
+ fi
+ fi
+ fi
+}
diff --git a/sci-mathematics/kodkodi/metadata.xml b/sci-mathematics/kodkodi/metadata.xml
new file mode 100644
index 000000000000..bcd7cbb8bab8
--- /dev/null
+++ b/sci-mathematics/kodkodi/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+</maintainer>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+A text front-end for the Kodkod Java library.
+</longdescription>
+<use>
+ <flag name='isabelle'>Add integration support for the Isabelle/HOL
+ theorem prover.</flag>
+</use>
+</pkgmetadata>