summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2017-04-26 18:42:42 +1000
committerMark Wright <gienah@gentoo.org>2017-04-26 18:43:22 +1000
commit01bdf0bb499aa42200b8544622fe706020d7949b (patch)
tree6015c4fba58abd76a6bd53f57b489c10928a1c27 /sci-mathematics/rstudio/rstudio-1.0.136.ebuild
parentmedia-sound/qmidiroute: Bump to 0.4.0, switch to qt5 (diff)
downloadgentoo-01bdf0bb499aa42200b8544622fe706020d7949b.tar.gz
gentoo-01bdf0bb499aa42200b8544622fe706020d7949b.tar.bz2
gentoo-01bdf0bb499aa42200b8544622fe706020d7949b.zip
sci-mathematics/rstudio: Bump to 1.0.143, fix 609644 and 606166.
Thanks to Matthias Schwartz for reporting 606166. Thanks to malices.gossips for reporting 609644, and kensington for the fix. Gentoo-Bug: 606166, 609644 Package-Manager: portage-2.3.5
Diffstat (limited to 'sci-mathematics/rstudio/rstudio-1.0.136.ebuild')
-rw-r--r--sci-mathematics/rstudio/rstudio-1.0.136.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-mathematics/rstudio/rstudio-1.0.136.ebuild b/sci-mathematics/rstudio/rstudio-1.0.136.ebuild
index fd16cfb0c906..dcb101cac4e3 100644
--- a/sci-mathematics/rstudio/rstudio-1.0.136.ebuild
+++ b/sci-mathematics/rstudio/rstudio-1.0.136.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit eutils user cmake-utils gnome2-utils pam versionator fdo-mime java-pkg-2 pax-utils
+inherit eutils user cmake-utils gnome2-utils pam versionator fdo-mime java-pkg-2 pax-utils qmake-utils
# TODO
# * package gin and gwt
@@ -57,7 +57,7 @@ RDEPEND="
>=dev-libs/mathjax-2.7.0
dev-libs/openssl:0
sys-apps/util-linux
- >=sys-devel/clang-3.5.0
+ >=sys-devel/clang-3.5.0:*
sys-libs/zlib
>=virtual/jre-1.8:=
x11-libs/pango
@@ -70,7 +70,7 @@ RDEPEND="
>=dev-qt/qtopengl-${QT_VER}:${QT_SLOT}
>=dev-qt/qtpositioning-${QT_VER}:${QT_SLOT}
>=dev-qt/qtprintsupport-${QT_VER}:${QT_SLOT}
- >=dev-qt/qtsingleapplication-2.6.1_p20150629[qt5]
+ >=dev-qt/qtsingleapplication-2.6.1_p20150629[X,qt5]
>=dev-qt/qtsensors-${QT_VER}:${QT_SLOT}
>=dev-qt/qtsql-${QT_VER}:${QT_SLOT}
>=dev-qt/qtsvg-${QT_VER}:${QT_SLOT}
@@ -172,7 +172,7 @@ src_prepare() {
# qmake spec, and then sed this into the patched src/cpp/desktop/CMakeLists.txt.
rm -rf "${S}"/src/cpp/desktop/3rdparty || die
local s=$(grep '\-lQt$${QT_MAJOR_VERSION}Solutions_SingleApplication' \
- "${EROOT}"/usr/lib64/qt5/mkspecs/features/qtsingleapplication.prf \
+ $(qt5_get_mkspecsdir)/features/qtsingleapplication.prf \
| sed -e 's@\$\${QT_MAJOR_VERSION}@5@' \
-e 's@LIBS \*= -l@@')
sed -e "s@Qt5Solutions_SingleApplication-2.6@${s}@g" \
@@ -195,7 +195,7 @@ src_configure() {
-DDISTRO_SHARE=share/${PN}
-DRSTUDIO_INSTALL_FREEDESKTOP="$(usex !dedicated "ON" "OFF")"
-DRSTUDIO_TARGET=$(usex dedicated "Server" "$(usex server "Development" "Desktop")")
- -DQT_QMAKE_EXECUTABLE="${EROOT}"usr/lib64/qt5/bin/qmake
+ -DQT_QMAKE_EXECUTABLE=$(qt5_get_bindir)/qmake
-DRSTUDIO_VERIFY_R_VERSION=FALSE
)