summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Hajdan, Jr <phajdan.jr@gentoo.org>2016-01-09 12:59:54 +0100
committerPawel Hajdan, Jr <phajdan.jr@gentoo.org>2016-01-09 13:00:49 +0100
commit4ab1ec46b906ee138dabf798d8b48ed4a7fcd580 (patch)
tree61921e1953a1b78b232d01f08e99ec15d02d877e /sci-mathematics/spin/spin-6.4.5.ebuild
parentwww-apps/moodle: version bumps 2.7.12, 2.8.10, 2.9.4, 3.0.1 (diff)
downloadgentoo-4ab1ec46b906ee138dabf798d8b48ed4a7fcd580.tar.gz
gentoo-4ab1ec46b906ee138dabf798d8b48ed4a7fcd580.tar.bz2
gentoo-4ab1ec46b906ee138dabf798d8b48ed4a7fcd580.zip
sci-mathematics/spin: version bump (6.4.5); now the license is BSD
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-mathematics/spin/spin-6.4.5.ebuild')
-rw-r--r--sci-mathematics/spin/spin-6.4.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/spin/spin-6.4.5.ebuild b/sci-mathematics/spin/spin-6.4.5.ebuild
new file mode 100644
index 000000000000..5b32111f7a6e
--- /dev/null
+++ b/sci-mathematics/spin/spin-6.4.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV=$(replace_all_version_separators '')
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="Tool for formal verification of distributed software systems"
+HOMEPAGE="http://spinroot.com/"
+SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graphviz tk"
+
+DEPEND="sys-devel/bison"
+RDEPEND="sys-devel/gcc
+ sys-process/time
+ tk? (
+ dev-lang/tk
+ graphviz? ( media-gfx/graphviz )
+ )"
+
+S="${WORKDIR}/Spin/Src${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.4.5-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin spin
+ doman ../Man/spin.1
+ dodoc ../Doc/*
+ if use tk; then
+ newbin "${WORKDIR}/Spin/iSpin/ispin.tcl" ispin
+ make_desktop_entry ispin
+ fi
+}