summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-06-30 19:44:21 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-06-30 19:44:21 +0700
commit05bbbf5c83766df67a9d4a98129014b2138a51b7 (patch)
tree942e409d2337fd85f6840bd5e6d24e6d945c9722 /sci-mathematics
parentsci-mathematics/fricas: bump to 1.3.11 (diff)
downloadgentoo-05bbbf5c83766df67a9d4a98129014b2138a51b7.tar.gz
gentoo-05bbbf5c83766df67a9d4a98129014b2138a51b7.tar.bz2
gentoo-05bbbf5c83766df67a9d4a98129014b2138a51b7.zip
sci-mathematics/fricas: remove old version
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/fricas/Manifest1
-rw-r--r--sci-mathematics/fricas/files/fricas-sbcl-2.3.9.patch59
-rw-r--r--sci-mathematics/fricas/fricas-1.3.9-r3.ebuild85
3 files changed, 0 insertions, 145 deletions
diff --git a/sci-mathematics/fricas/Manifest b/sci-mathematics/fricas/Manifest
index 5ab55abf98ec..6c0959685da2 100644
--- a/sci-mathematics/fricas/Manifest
+++ b/sci-mathematics/fricas/Manifest
@@ -1,3 +1,2 @@
DIST fricas-1.3.10-full.tar.bz2 10971513 BLAKE2B 0ea96cf1076dcd23f53ebdcd3ebf5c6e605915ce332093b83d62a5ed482d32f14833857e270865a4031d7bfc033d961c69007e936260e7d85e632b091d969e0d SHA512 de23c34a1e47b0a4ab2f85e1154e6fa5b0905427718e8c0ad4fe298bf6ebbb1abcc02426e528b7b34d15aebfc2ca1b06f73e39a24ec741d2d5c70f9b48b02665
DIST fricas-1.3.11-full.tar.bz2 10937641 BLAKE2B 52bb467468de83dfbb8a61717356d74c605efe1174168c35af50d15232c8441457415ca2c88fd19356caec9f9ee29af556104f421dc0479f3ae635144432be7a SHA512 6166661866829764fdf02e84c08f3afd8f631a40c8c5340648640b4fa388641c703021f5006e135ac32e671786b1a75bc290039e929ef322c60a0ba0cb0212ac
-DIST fricas-1.3.9-full.tar.bz2 10949173 BLAKE2B c535d2a384fa55db53b6901d3ba5d1cc8eca35ccf67a2664f934da427a808b5adc7a5522b935f5dcff89795c0ca5816818d9cf37399b6f9bdc63cfe4d622a7c3 SHA512 9cfcb8bad52550a46216509154d5c06dac23625bc14d504a1febbea7ff771fd3172f91c2824df51375b8d85adc19959a5cbbfa2b77a0095ca37e8a4d4b8cc405
diff --git a/sci-mathematics/fricas/files/fricas-sbcl-2.3.9.patch b/sci-mathematics/fricas/files/fricas-sbcl-2.3.9.patch
deleted file mode 100644
index f3a28ed57457..000000000000
--- a/sci-mathematics/fricas/files/fricas-sbcl-2.3.9.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff --git a/src/lisp/num_gmp.lisp b/src/lisp/num_gmp.lisp
-index b58001e0b..f4a022ad4 100644
---- a/src/lisp/num_gmp.lisp
-+++ b/src/lisp/num_gmp.lisp
-@@ -646,14 +646,27 @@
- (setf (symbol-function 'orig-isqrt)
- (symbol-function 'common-lisp:isqrt)))
-
-+(defmacro negate_bignum(x)
-+ (let ((sym2
-+ (find-symbol "NEGATE-BIGNUM-NOT-FULLY-NORMALIZED" "SB-BIGNUM")))
-+ (if sym2
-+ `(,sym2 ,x)
-+ ;;; 'read-from-string' looks silly, but here we want error
-+ ;;; if NEGATE-BIGNUM is absent from SB-BIGNUM
-+ (let ((sym1 (read-from-string "SB-BIGNUM::NEGATE-BIGNUM")))
-+ `(,sym1 ,x nil))
-+ )
-+ )
-+)
-+
- (defun gmp-multiply-bignums0 (a b)
- ;;; (declare (type bignum-type a b))
- (let* ((a-plusp (sb-bignum::%bignum-0-or-plusp a
- (sb-bignum::%bignum-length a)))
- (b-plusp (sb-bignum::%bignum-0-or-plusp b
- (sb-bignum::%bignum-length b)))
-- (a (if a-plusp a (sb-bignum::negate-bignum a)))
-- (b (if b-plusp b (sb-bignum::negate-bignum b)))
-+ (a (if a-plusp a (negate_bignum a)))
-+ (b (if b-plusp b (negate_bignum b)))
- (len-a (sb-bignum::%bignum-length a))
- (len-b (sb-bignum::%bignum-length b))
- (len-res (+ len-a len-b))
-@@ -697,10 +710,10 @@
- (let* (
- (nx (if (sb-bignum::%bignum-0-or-plusp x (sb-bignum::%bignum-length x))
- (sb-bignum::copy-bignum x)
-- (sb-bignum::negate-bignum x nil)))
-+ (negate_bignum x)))
- (ny (if (sb-bignum::%bignum-0-or-plusp y (sb-bignum::%bignum-length y))
- (sb-bignum::copy-bignum y)
-- (sb-bignum::negate-bignum y nil)))
-+ (negate_bignum y)))
- (xl (sb-bignum::%bignum-length nx))
- (yl (sb-bignum::%bignum-length ny))
- (rl (if (< xl yl) xl yl))
-@@ -735,9 +748,9 @@
- (x-plusp (sb-bignum::%bignum-0-or-plusp x (sb-bignum::%bignum-length x)))
- (y-plusp (sb-bignum::%bignum-0-or-plusp y (sb-bignum::%bignum-length y)))
- (nx (if x-plusp x
-- (sb-bignum::negate-bignum x nil)))
-+ (negate_bignum x)))
- (ny (if y-plusp y
-- (sb-bignum::negate-bignum y nil)))
-+ (negate_bignum y)))
- (len-x (sb-bignum::%bignum-length nx))
- (len-y (sb-bignum::%bignum-length ny))
- (q nil)
diff --git a/sci-mathematics/fricas/fricas-1.3.9-r3.ebuild b/sci-mathematics/fricas/fricas-1.3.9-r3.ebuild
deleted file mode 100644
index 0fc1aceea768..000000000000
--- a/sci-mathematics/fricas/fricas-1.3.9-r3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit elisp-common
-
-DESCRIPTION="FriCAS is a fork of Axiom computer algebra system"
-HOMEPAGE="https://fricas.sourceforge.net/
- https://github.com/fricas/fricas
- https://fricas.github.io/"
-SRC_URI="https://downloads.sourceforge.net/${PN}/${PV}/${P}-full.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="+sbcl cmucl gcl ecl clisp clozurecl X emacs gmp"
-REQUIRED_USE="^^ ( sbcl cmucl gcl ecl clisp clozurecl )
- gmp? ( ^^ ( sbcl clozurecl ) )"
-RDEPEND="sbcl? ( dev-lisp/sbcl:= )
- cmucl? ( dev-lisp/cmucl:= )
- gcl? ( dev-lisp/gcl:= )
- ecl? ( dev-lisp/ecl:= )
- clisp? ( dev-lisp/clisp:= )
- clozurecl? ( dev-lisp/clozurecl:= )
- X? ( x11-libs/libXpm x11-libs/libICE )
- emacs? ( >=app-editors/emacs-23.1:* )
- gmp? ( dev-libs/gmp:= )"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-sbcl-2.3.9.patch )
-
-# necessary for clisp and gcl
-RESTRICT="strip"
-
-src_configure() {
- local LISP GMP
- use sbcl && LISP=sbcl
- use cmucl && LISP=lisp
- use gcl && LISP=gcl
- use ecl && LISP=ecl
- use clisp && LISP=clisp
- use clozurecl && LISP=ccl
-
- if use sbcl || use clozurecl
- then GMP=$(use_with gmp)
- else GMP=''
- fi
-
- # aldor is not yet in portage
- econf --disable-aldor --with-lisp=${LISP} $(use_with X x) ${GMP}
-}
-
-src_compile() {
- # bug #300132
- emake -j1
-}
-
-src_test() {
- emake -j1 all-input
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install
- dodoc README.rst FAQ
-
- if use emacs; then
- sed -e "s|(setq load-path (cons (quote \"/usr/$(get_libdir)/fricas/emacs\") load-path)) ||" \
- -i "${D}"/usr/bin/efricas \
- || die "sed efricas failed"
- elisp-install ${PN} "${D}"/usr/$(get_libdir)/${PN}/emacs/*.el
- elisp-make-site-file 64${PN}-gentoo.el
- else
- rm "${D}"/usr/bin/efricas || die "rm efricas failed"
- fi
- rm -r "${D}"/usr/$(get_libdir)/${PN}/emacs || die "rm -r emacs failed"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}