summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-17 16:44:06 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-17 17:46:31 +0200
commit785449be0e7877c1b02a0922ea5783c56c21bc90 (patch)
tree59b8700d1cc5722b3c4194ac59fa94c19f51132b /sci-mathematics
parentsci-mathematics/alt-ergo: remove zarith pin; add ocplib-simplex-0.5 pin (diff)
downloadgentoo-785449be0e7877c1b02a0922ea5783c56c21bc90.tar.gz
gentoo-785449be0e7877c1b02a0922ea5783c56c21bc90.tar.bz2
gentoo-785449be0e7877c1b02a0922ea5783c56c21bc90.zip
sci-mathematics/alt-ergo: remove broken live 9999
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-9999.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-9999.ebuild b/sci-mathematics/alt-ergo/alt-ergo-9999.ebuild
deleted file mode 100644
index 1ba42319bb6c..000000000000
--- a/sci-mathematics/alt-ergo/alt-ergo-9999.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit dune
-
-DESCRIPTION="Automatic theorem prover"
-HOMEPAGE="https://alt-ergo.ocamlpro.com
- https://github.com/OCamlPro/alt-ergo/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/OCamlPro/${PN}.git"
-else
- SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="CeCILL-C"
-SLOT="0/${PV}"
-IUSE="examples gui +ocamlopt"
-REQUIRED_USE="ocamlopt"
-
-RDEPEND="
- >=dev-lang/ocaml-4.09.0:=[ocamlopt=]
- >=sci-mathematics/psmt2-frontend-0.4.0:=
-
- >=dev-ml/cmdliner-1.1.0:=
- >=dev-ml/menhir-20181006:=
- >=dev-ml/ocplib-simplex-0.4:=
- dev-ml/camlzip:=
- dev-ml/num:=
- dev-ml/stdlib-shims:=
- dev-ml/zarith:=
- gui? (
- dev-ml/lablgtk:3
- dev-ml/lablgtk-sourceview:3
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-ml/dune-build-info
- dev-ml/dune-configurator
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-2.4.3-dune.patch )
-
-OCAML_SUBPACKAGES=(
- alt-ergo-lib
- alt-ergo-parsers
- alt-ergo
-)
-
-src_prepare() {
- default
-
- if use gui ; then
- OCAML_SUBPACKAGES+=( altgr-ergo )
- fi
-}
-
-src_configure() {
- sh ./configure --prefix /usr --libdir=/usr/$(get_libdir) || die
-}
-
-src_compile() {
- dune-compile ${OCAML_SUBPACKAGES[@]}
-}
-
-src_install() {
- dune-install ${OCAML_SUBPACKAGES[@]}
-
- use examples && dodoc -r examples
-}