summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-11-13 23:03:15 -0600
committerMatthias Maier <tamiko@gentoo.org>2019-11-14 00:01:51 -0600
commitc3779321f75d53fe0a5e1b261d4047c9df9f892d (patch)
tree8246d061093bd69ae747f4cff7cae3fc795281c4 /sci-mathematics
parentsci-mathematics/petsc: version bump to 3.12.1 (diff)
downloadgentoo-c3779321f75d53fe0a5e1b261d4047c9df9f892d.tar.gz
gentoo-c3779321f75d53fe0a5e1b261d4047c9df9f892d.tar.bz2
gentoo-c3779321f75d53fe0a5e1b261d4047c9df9f892d.zip
sci-mathematics/slepc: version bump to 3.12.1
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/slepc/Manifest1
-rw-r--r--sci-mathematics/slepc/slepc-3.12.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sci-mathematics/slepc/Manifest b/sci-mathematics/slepc/Manifest
index a1f5cfb711c1..d23b2beb677f 100644
--- a/sci-mathematics/slepc/Manifest
+++ b/sci-mathematics/slepc/Manifest
@@ -1 +1,2 @@
DIST slepc-3.11.1.tar.gz 4700643 BLAKE2B a624050aad0128d7ef53f27f72484e078e62d8edf9298995dda71a9e8d804dddc7e433542eccf95b2d896be80e8795b1664375e68a4c02c18c56d78d490bffb7 SHA512 a941c2a955953ed2344de7f7d9eaaed79504c3559e27920c633bc09cfb192f883b26fd4aa5dc3bd9909a2fc045f3a34e514feca0e074ca36bc3166aa9c059235
+DIST slepc-3.12.1.tar.gz 4757436 BLAKE2B 607e7b28730ff16fa995768e23fd9861e180c078d2f06e8f65324b1e1761f0688fe5a4c4420983b521583cb2b3fe28b606baea604daf5253c30131f9f54c5572 SHA512 0254ea1a521cf150f9f0402bb936c9d1aa32765264e055ecdd058e44aaa7e87c3df1b63b1889c1989c4a691c652eb0f248a1bbbe6d555ce16f9f8f28d6765b50
diff --git a/sci-mathematics/slepc/slepc-3.12.1.ebuild b/sci-mathematics/slepc/slepc-3.12.1.ebuild
new file mode 100644
index 000000000000..52212cabfd52
--- /dev/null
+++ b/sci-mathematics/slepc/slepc-3.12.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
+HOMEPAGE="http://slepc.upv.es/"
+SRC_URI="http://slepc.upv.es/download/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="complex-scalars doc mpi"
+
+RDEPEND="
+ =sci-mathematics/petsc-$(ver_cut 1-2)*:=[mpi=,complex-scalars=]
+ sci-libs/arpack[mpi=]
+ mpi? ( virtual/mpi )
+"
+
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ dev-util/cmake
+"
+
+MAKEOPTS="${MAKEOPTS} V=1"
+
+src_prepare() {
+ default
+
+ sed -i -e 's%/usr/bin/env python%/usr/bin/env python2%' configure || die
+}
+
+src_configure() {
+ # *sigh*
+ addpredict "${PETSC_DIR}"/.nagged
+
+ # Make sure that the environment is set up correctly:
+ unset PETSC_DIR
+ unset PETSC_ARCH
+ unset SLEPC_DIR
+ source "${EPREFIX}"/etc/env.d/99petsc
+ export PETSC_DIR
+
+ # configure is a custom python script and doesn't want to have default
+ # configure arguments that we set with econf
+ ./configure \
+ --prefix="${EPREFIX}/usr/$(get_libdir)/slepc" \
+ --with-arpack=1 \
+ --with-arpack-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-arpack-flags="$(usex mpi "-lparpack,-larpack" "-larpack")"
+
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # add PETSC_DIR to environmental variables
+ cat >> 99slepc <<- EOF
+ SLEPC_DIR=${EPREFIX}/usr/$(get_libdir)/slepc
+ LDPATH=${EPREFIX}/usr/$(get_libdir)/slepc/lib
+ EOF
+ doenvd 99slepc
+
+ if use doc ; then
+ dodoc docs/slepc.pdf
+ docinto html
+ dodoc -r docs/*.html docs/manualpages
+ fi
+}