summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-27 23:55:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-28 00:42:21 +0200
commitd38c26529bb8b6d68b0cc29530d974ed2df2f8b0 (patch)
tree73d37b0014909299f66e4e525a756b2a3d948cb2 /sci-mathematics
parentsci-mathematics/cadical: drop old 1.9.4 (diff)
downloadgentoo-d38c26529bb8b6d68b0cc29530d974ed2df2f8b0.tar.gz
gentoo-d38c26529bb8b6d68b0cc29530d974ed2df2f8b0.tar.bz2
gentoo-d38c26529bb8b6d68b0cc29530d974ed2df2f8b0.zip
sci-mathematics/cadical: bump to 2.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cadical/Manifest1
-rw-r--r--sci-mathematics/cadical/cadical-2.0.0.ebuild49
-rw-r--r--sci-mathematics/cadical/files/cadical-makefile-in-respect-ar-2.0.0.patch11
3 files changed, 61 insertions, 0 deletions
diff --git a/sci-mathematics/cadical/Manifest b/sci-mathematics/cadical/Manifest
index 757e3db820e8..63a48e3bd0b1 100644
--- a/sci-mathematics/cadical/Manifest
+++ b/sci-mathematics/cadical/Manifest
@@ -1 +1,2 @@
DIST cadical-1.9.5.tar.gz 691268 BLAKE2B 68c7fcc35ef0ad5082d5bbc828363ee45c2e637f281f1829ffb34047fff73775d34615e0ac37b8b49ff20b941db85b72c0dd6de0ab5ec5a690fd80fb5489b212 SHA512 b40727847ba0217f8d24e5468874264065c5ec9cbf0600d2e2395b8396a9d5f892127018ab9d1b930599a16a0817de5b0d29136c5dc74f2a72fb0f726e825271
+DIST cadical-2.0.0.tar.gz 709136 BLAKE2B 76b738aef8063b96b11098be132bd9921cc6e4f39efe4c14916e1b9fb9517f464771a8f4fcc116a1a37fcd44b71513bb94516b3c81699f4d5417dde0e69ddb0c SHA512 5ec4d43751e36844afcfc9102e71a2fc1e5b1112506eb654e3aef7f2ba425738264b73b88b0400ec15222c8a9d2f4d37a1f60da69a0c061303904b7ad0a93885
diff --git a/sci-mathematics/cadical/cadical-2.0.0.ebuild b/sci-mathematics/cadical/cadical-2.0.0.ebuild
new file mode 100644
index 000000000000..0d4bf08a816c
--- /dev/null
+++ b/sci-mathematics/cadical/cadical-2.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplified Satisfiability Solver"
+HOMEPAGE="http://fmv.jku.at/cadical/
+ https://github.com/arminbiere/cadical/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/arminbiere/${PN}.git"
+else
+ SRC_URI="https://github.com/arminbiere/${PN}/archive/rel-${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-rel-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-configure.patch"
+ "${FILESDIR}/${PN}-makefile-in-respect-ar-2.0.0.patch"
+)
+
+DOCS=( CONTRIBUTING.md NEWS.md README.md )
+
+src_configure() {
+ tc-export AR
+
+ CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" ./configure || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe build/{cadical,mobical}
+
+ dolib.a build/libcadical.a
+ doheader src/cadical.hpp
+ doheader src/ccadical.h
+
+ einstalldocs
+}
diff --git a/sci-mathematics/cadical/files/cadical-makefile-in-respect-ar-2.0.0.patch b/sci-mathematics/cadical/files/cadical-makefile-in-respect-ar-2.0.0.patch
new file mode 100644
index 000000000000..61787b76f29e
--- /dev/null
+++ b/sci-mathematics/cadical/files/cadical-makefile-in-respect-ar-2.0.0.patch
@@ -0,0 +1,11 @@
+--- a/makefile.in
++++ b/makefile.in
+@@ -60,7 +60,7 @@ mobical: src/mobical.o libcadical.a makefile $(LIBS)
+ $(COMPILE) -o $@ $< -L. -lcadical
+
+ libcadical.a: $(OBJ_SOLVER) $(OBJ_CONTRIB) makefile
+- ar rc $@ $(OBJ_SOLVER) $(OBJ_CONTRIB)
++ ${AR} rc $@ $(OBJ_SOLVER) $(OBJ_CONTRIB)
+
+ #--------------------------------------------------------------------------#
+