summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-22 17:35:05 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-25 21:48:54 +0200
commitbbc6ea1658e5e56d7e5f1ac354b701c04a25152d (patch)
tree31b9b37bb3f96bf782eebe5ba02d33093523c488 /sci-misc/ncview/ncview-2.1.7.ebuild
parentsci-mathematics/xmds: Version bump to 2.2.2 and porting to EAPI 6 (diff)
downloadgentoo-bbc6ea1658e5e56d7e5f1ac354b701c04a25152d.tar.gz
gentoo-bbc6ea1658e5e56d7e5f1ac354b701c04a25152d.tar.bz2
gentoo-bbc6ea1658e5e56d7e5f1ac354b701c04a25152d.zip
sci-misc/ncview: Version bump to 2.1.7 + EAPI bump 4 -> 6
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2388 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-misc/ncview/ncview-2.1.7.ebuild')
-rw-r--r--sci-misc/ncview/ncview-2.1.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-misc/ncview/ncview-2.1.7.ebuild b/sci-misc/ncview/ncview-2.1.7.ebuild
new file mode 100644
index 000000000000..e0afa6ef84ab
--- /dev/null
+++ b/sci-misc/ncview/ncview-2.1.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="X-based viewer for netCDF files"
+HOMEPAGE="http://meteora.ucsd.edu/~pierce/ncview_home_page.html"
+SRC_URI="ftp://cirrus.ucsd.edu/pub/ncview/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="media-libs/libpng:0=
+ >=sci-libs/netcdf-4.1[hdf5]
+ x11-libs/libXaw
+ sci-libs/udunits"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+
+ doman data/${PN}.1
+
+ insinto /usr/share/X11/app-defaults
+ newins Ncview-appdefaults Ncview
+
+ insinto /usr/share/${PN}
+ doins *.ncmap
+
+ make_desktop_entry ${PN}
+}