summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2024-12-02 16:29:07 +0100
committerGuilherme Amadio <amadio@gentoo.org>2024-12-03 15:19:12 +0100
commit8cb7209bd1e5f944228a9a823856d099cf87ba7f (patch)
treeb2cd584250c64f1c919a1f57f4fcf1a954ddad0e /sci-physics
parentdev-ruby/rails-html-sanitizer: add 1.6.1 (diff)
downloadgentoo-8cb7209bd1e5f944228a9a823856d099cf87ba7f.tar.gz
gentoo-8cb7209bd1e5f944228a9a823856d099cf87ba7f.tar.bz2
gentoo-8cb7209bd1e5f944228a9a823856d099cf87ba7f.zip
sci-physics/root: remove USE=qt5 from live ebuilds
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-6.34.9999.ebuild11
-rw-r--r--sci-physics/root/root-9999.ebuild11
2 files changed, 6 insertions, 16 deletions
diff --git a/sci-physics/root/root-6.34.9999.ebuild b/sci-physics/root/root-6.34.9999.ebuild
index f0e0690cfb51..0c7cfa523aa8 100644
--- a/sci-physics/root/root-6.34.9999.ebuild
+++ b/sci-physics/root/root-6.34.9999.ebuild
@@ -16,7 +16,7 @@ LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+gdml graphviz +gsl +http jupyter libcxx +minuit mpi mysql odbc +opengl
- postgres pythia8 +python qt5 qt6 R +roofit +root7 shadow sqlite +ssl
+ postgres pythia8 +python qt6 R +roofit +root7 shadow sqlite +ssl
+tbb test +tmva +unuran uring vc +xml xrootd"
if [[ ${PV} =~ "9999" ]] ; then
@@ -40,11 +40,10 @@ PROPERTIES="test_network"
REQUIRED_USE="
cuda? ( tmva )
cudnn? ( cuda )
- !X? ( !asimage !opengl !qt5 !qt6 )
+ !X? ( !asimage !opengl !qt6 )
davix? ( ssl xml )
jupyter? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
- qt5? ( root7 http )
qt6? ( root7 http )
roofit? ( minuit )
tmva? ( gsl python )
@@ -77,10 +76,6 @@ CDEPEND="
virtual/glu
x11-libs/gl2ps:0=
)
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtwebengine:5[widgets]
- )
qt6? (
dev-qt/qtbase:6
dev-qt/qtwebengine:6[widgets]
@@ -270,7 +265,7 @@ src_configure() {
-Dpgsql=$(usex postgres)
-Dpyroot=$(usex python) # python was renamed to pyroot
-Dpythia8=$(usex pythia8)
- -Dqt5web=$(usex qt5)
+ -Dqt5web=OFF # $(usex qt5)
-Dqt6web=$(usex qt6)
-Dr=$(usex R)
-Droofit=$(usex roofit)
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index f0e0690cfb51..0c7cfa523aa8 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -16,7 +16,7 @@ LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+gdml graphviz +gsl +http jupyter libcxx +minuit mpi mysql odbc +opengl
- postgres pythia8 +python qt5 qt6 R +roofit +root7 shadow sqlite +ssl
+ postgres pythia8 +python qt6 R +roofit +root7 shadow sqlite +ssl
+tbb test +tmva +unuran uring vc +xml xrootd"
if [[ ${PV} =~ "9999" ]] ; then
@@ -40,11 +40,10 @@ PROPERTIES="test_network"
REQUIRED_USE="
cuda? ( tmva )
cudnn? ( cuda )
- !X? ( !asimage !opengl !qt5 !qt6 )
+ !X? ( !asimage !opengl !qt6 )
davix? ( ssl xml )
jupyter? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
- qt5? ( root7 http )
qt6? ( root7 http )
roofit? ( minuit )
tmva? ( gsl python )
@@ -77,10 +76,6 @@ CDEPEND="
virtual/glu
x11-libs/gl2ps:0=
)
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtwebengine:5[widgets]
- )
qt6? (
dev-qt/qtbase:6
dev-qt/qtwebengine:6[widgets]
@@ -270,7 +265,7 @@ src_configure() {
-Dpgsql=$(usex postgres)
-Dpyroot=$(usex python) # python was renamed to pyroot
-Dpythia8=$(usex pythia8)
- -Dqt5web=$(usex qt5)
+ -Dqt5web=OFF # $(usex qt5)
-Dqt6web=$(usex qt6)
-Dr=$(usex R)
-Droofit=$(usex roofit)