summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-09 14:31:15 +0000
committerSam James <sam@gentoo.org>2023-01-10 03:46:52 +0000
commitde13f46f79478ea73c229a0dd5122a6cb83d8ab1 (patch)
tree600b07207aeff0b21d7e4d71d6b857c5756da10a /sci-physics
parentapp-forensics/aflplusplus: drop 4.01c-r1 (diff)
downloadgentoo-de13f46f79478ea73c229a0dd5122a6cb83d8ab1.tar.gz
gentoo-de13f46f79478ea73c229a0dd5122a6cb83d8ab1.tar.bz2
gentoo-de13f46f79478ea73c229a0dd5122a6cb83d8ab1.zip
sci-physics/reduze: switch to sys-libs/db:5.3
This version has a more permissive licence and reduze was the only consumer left of 6.0. Dropping it will allow us to remove db:6.0. Sadly, reduze does not build with 4.8, which is the main bdb version. Signed-off-by: Sam James <sam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/29032 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/reduze/files/reduze-2.2-db.patch2
-rw-r--r--sci-physics/reduze/reduze-2.4-r1.ebuild (renamed from sci-physics/reduze/reduze-2.4.ebuild)12
2 files changed, 8 insertions, 6 deletions
diff --git a/sci-physics/reduze/files/reduze-2.2-db.patch b/sci-physics/reduze/files/reduze-2.2-db.patch
index a43de911be7a..92c7e46d3cdf 100644
--- a/sci-physics/reduze/files/reduze-2.2-db.patch
+++ b/sci-physics/reduze/files/reduze-2.2-db.patch
@@ -6,7 +6,7 @@ diff -r -U2 a/reduze/CMakeLists.txt b/reduze/CMakeLists.txt
find_path(DB_INCLUDE_PATH NAMES dbstl_common.h
- PATHS /usr/local/include/db4 /usr/local/include
- /usr/include/db4 /usr/include)
-+ PATHS /usr/include/db6.0)
++ PATHS /usr/include/db5.3)
# we also need db.h but just assume its in the same directory
find_library(DB_LIBRARY NAMES db_stl
- PATHS /usr/lib /usr/local/lib)
diff --git a/sci-physics/reduze/reduze-2.4.ebuild b/sci-physics/reduze/reduze-2.4-r1.ebuild
index c7ea66e3ee54..218b666b890d 100644
--- a/sci-physics/reduze/reduze-2.4.ebuild
+++ b/sci-physics/reduze/reduze-2.4-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -16,12 +16,14 @@ IUSE="berkdb doc examples mpi"
RDEPEND="
>=sci-mathematics/ginac-1.4.1
- berkdb? ( sys-libs/db:6.0[cxx] )
- mpi? ( virtual/mpi )"
+ berkdb? ( sys-libs/db:5.3=[cxx] )
+ mpi? ( virtual/mpi )
+"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+"
PATCHES=(
"${FILESDIR}"/${P}-cmake.patch