summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormsathieu <msathieu@outlook.com>2021-11-03 08:05:14 +0100
committerSam James <sam@gentoo.org>2021-11-12 02:08:33 +0000
commit4c323d9678e0995f16a9112a60d6ac51e005b178 (patch)
treee0542b254fb2c53644a1ec185171f5c023506771 /sec-policy/apparmor-profiles/apparmor-profiles-3.0.3.ebuild
parentsys-apps/apparmor-utils: update to 3.0.3 (diff)
downloadgentoo-4c323d9678e0995f16a9112a60d6ac51e005b178.tar.gz
gentoo-4c323d9678e0995f16a9112a60d6ac51e005b178.tar.bz2
gentoo-4c323d9678e0995f16a9112a60d6ac51e005b178.zip
sec-policy/apparmor-profiles: update to 3.0.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mathieu Strypsteen <msathieu@outlook.com> Closes: https://github.com/gentoo/gentoo/pull/22788 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sec-policy/apparmor-profiles/apparmor-profiles-3.0.3.ebuild')
-rw-r--r--sec-policy/apparmor-profiles/apparmor-profiles-3.0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sec-policy/apparmor-profiles/apparmor-profiles-3.0.3.ebuild b/sec-policy/apparmor-profiles/apparmor-profiles-3.0.3.ebuild
new file mode 100644
index 000000000000..b64a0b8aa1b0
--- /dev/null
+++ b/sec-policy/apparmor-profiles/apparmor-profiles-3.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+DESCRIPTION="A collection of profiles for the AppArmor application security system"
+HOMEPAGE="https://gitlab.com/apparmor/apparmor/wikis/home"
+SRC_URI="https://launchpad.net/apparmor/${MY_PV}/${PV}/+download/apparmor-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="minimal"
+
+RESTRICT="test"
+
+S=${WORKDIR}/apparmor-${PV}/profiles
+
+src_install() {
+ if use minimal ; then
+ insinto /etc/apparmor.d
+ doins -r apparmor.d/{abi,abstractions,tunables}
+ else
+ default
+ fi
+}